Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma G7020 won't connect to WiFi on Windows 11


I have the G7020 printer connected to my network via WiFi. I downloaded the latest G7020 software on my Windows 11 PC, and then I run the software and get to this point:

Printer was foundPrinter was found


So the printer was found on the WiFi network.  I then continue the installation process and it gets to this screen:

Connection failedConnection failed

I've tried everything and Googled for an answer but cannot get the printer connected!  I've even tried connecting the printer with a USB cable to get the network connection to no avail - it keeps coming up Connection failed.

Is there anything else I can do or try?



Happy Holidays,

Can you please tell us more about the network the printer is connecting to?

Router or access point is dual band, tri-band?  2.4Ghz/5G?  Do all broadcasts use the same SSID name?  Encryption type?  (WPA2) (WPA3)?

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hi - I have dual-band 2.5/5 Ghz eero 5 mesh router setup connected to my AT&T modem. There are 3 eero devices with the primary router being upstairs along with the printer in our office, and the other 2 eero are downstairs. All using the same SSID. The eero setup uses WPA2 encryption.

Also my Mac and phones have no issues connecting and printing to the printer, it’s just my Win 11 PC.

Let me know if there’s any other info you need.



No one else can assist or help?