cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA TS5120 will not prompt for password

janiekelley
Contributor

I recently moved and changed internet providers, and my printer will not connect to the internet because it will not prompt for a password when I try to set it up. 

Things that have NOT worked:
- Turning off and on (printer, router, computer, basically all things attached to this process)
- Hard reset / returning to factory settings
- Easy install via device
- Manual connect (will not prompt for password)
- Turning off roaming feature 802.11r (cannot do so with my service)
- Buying a cheap wifi repeater (unnecessary other than for the forking printer to work), adding repeater to network, adding printer to repeater. Will prompt for password now, but will not connect. Have tried multiple times. 

I have been told "buy a new printer" by a handful of users which is... less than helpful.

Canon, any info or advice?

2 REPLIES 2

shadowsports
Legend
Legend

Greetings,

Its not clear from your post whether you have re-run the software set up.  This is typically where you are able to modify the SSID and/or wireless password after a router change.

Canon Knowledge Base - Easy Wireless Connect Setup for Windows Computers - PIXMA TS5120

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Yes, the first type of install I attempted was a regular "easy install" (easy install via device), where I attempted to re-run the software setup. Since the printer will not connect, this did not work. I tried on multiple computers and two different phones.

Avatar
click here to view the press release
Announcements