cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MG6450 Another computer is using the printer

Yatesy1990
Apprentice

Up to now we've printed ok but yesterday our Windows 8 laptops report that "Another computer is using the prnter". We have a Canon MG6450 printer; ona  wireless network. We have rebooted our laptops; the router; and switched off printer but to no avail. Any other suggestions ?

 

Another computer is using the printer.
The following status is the usage status of that computer.
---
Creating print data

 

A follow up query is why is there a need to register is the need to send email docs to [Email address removed in accordance with forum guidelines] to get printed ? It is both time consuming, over elaborate and completely unnecessary to use a "Print from E-mail" service and " to complete the printer owner registration".

 

1 ACCEPTED SOLUTION

DaBoss
Apprentice

I solved my problem on the MG5520 using Windows 8.1 stuck with the "used by another computer" error!

 

I noticed in my settings (computer settings - devices - printers)  that there are two Canon printers listed - make sure you DO NOT select the printer that ends in "WS" when trying to print a document. EX:  "Canon MG5500 series printer" vs "Canon MG5500 series printer WS".

If you have any print jobs pending in that queue for that printer ending with "WS", then you will need to cancel all pending print jobs under the "WS" labeled printer before it will allow any other print job to be performed.

Next, when you go to print a document, make sure you select the correct printer (without "WS" at the end).

 

This cleared up the "being used by another computer" error, and I didn't have to uninstall or reinstall any drivers or disable any wireless settings or use a USB cable!

I was so happy that I even took the stupid half hour to register an account with Canon so I could share my solution to this annoying problem. And now I know that I should inform my wife to not print anything on the wrong printer queue anymore!

 

I hope this saves someone from the frustration I felt.

 

Here is a more discriptive walkthrough for technologically challenged individuals:

 

*This first part s not actually necessary - it is just to show you that there are two DIFFERENT print queues

Step 1:

Get into your PC settings menu. If you don't know how to get there, then go to your Apps screen and use the Search feature by typing in "settings". The first thing to pop up should be PC Settings (click on that).

Next, you have to select "PC and Devices" to the left of the screen

Then you want to select "Devices" to the let of the screen

There you will see a list of devices installed on your computer, and you should see two Canon printers (one ending in WS). EX:  "Canon MG5500 series printer" vs "Canon MG5500 series printer WS"

 

Step 2:

Log into each user profile on your computer and check the print queues to see who is trying to print on the "WS" printer queue.

You can see the print queue  by clicking on the little triangle in the bottom right of your screen, then clicking on the little printer icon.

If there are pending print jobs, cancel ALL of them for each user account on your computer.

 

Step 3:

Once all print queues are clear, try printing a document and be sure to select the printer WITHOUT "WS" at the end of the name and it should work!

 

Good luck!

View solution in original post

83 REPLIES 83

BardofL
Apprentice

I now have the same problem with my new Canon Maxima MG7120.

I am trying to print to it from my laptop running windows 8.1 pro and from a desktop running Windows 7 Ultimate.

What gives!!!!

 

The error message is as follows:

Another computer is using the printer.
The following status is the usage status of that computer.
---
Creating print data.
Ink is running low. View the ink details.

I changed the ink tank that was out but that didn't help. Do I need to change all the low tanks?

Changing all the ink tanks that were out or low did the trick.
Now it seems to work again. Just another crazy uninformative error message.

How do i get this cannon printer to work?

LindaK
Apprentice

Does anyone know the solution?  Very frustrating!

Yes, I suddenly starting have the exact same problem on my MG7100, which had been working fine until a few days ago. Have tried the same things as others here to no avail. Very frustrating.

I had the same symptom for the first time today with a MG5520, probably applies to other models. the Firmware is up to date.

I have 3 computers that can print to the printer from the wifi network in my house and a few others that print via Google Cloud Print from outside my home network.  After several trial an error attempts to resolve the issue, I discovered taht If I connect to the printer via the USB cable and then use the wifi setup page of the printer I was able to diable WSD support whcih allowed me to print via USB.  Prior to disabling WSD, I could not print via USB either, apparently the printer had a stuck print job that it would not let go of.

By disabling WSD it more or less gave up on that print job stream, but it will fail again if you simply enable it again.

 

I not 100% sure which of these next steps are necessary, but it did fix my scenario. 

1) conect via USB to the printer ( still can't print )

2) use the printer web interface located at it's wifi address on your network, if you don't what it is you may have to dig around in your router's DHCP list of connected devices.

3) use a web Browser to that address, click network configuration in the lower left hand corner.

4) click advanced in the lower right corner

5) click Other settings on the left

6) select the disable option on the WSD setting and click OK at the top of the screen, once the operation completes you can print via USB

7) change the name of the printer on the same Other settings page, has to be unique...

😎 re-enable WSD and click OK.

 

At this point you can use the standard Canon utilities installed on the computer with the USB connection to associate the Wifi printer and other computers on the netowrk can do the same.

I did not have to re-install the drivers, but it was almost as bad as that...  Time will tell how long until it happens again.

 

Hope someone can benefit from this solution.

oneintheeye
Apprentice

Hi There

 

I hope this fixes your problem too. We had the same issue and its seems to be related to a Canon App which you need to dowload for your printer from the Windows App Store.

 

I found the issue by 

 

1) Going to the cog which I think is settings tile in the Metro Interface

2) Then going to Devices

3) Then going to printers which shows your canon printer, one note printer and xps printer. 

 

I think I hovered over the canon and beneath was a box which said get app. Fearing nothing to lose I did and it went to the Windows App store and took a minute or two to download the app. Now I can print again!!!

 

Before doing the above you may want to open the printer in control panels and delete all the previous failed print docs.

 

Canon/Microsoft but please let your customers know if they now need and app to make their purchases work. We phoned the Canon support line and the lady had no idea how to fix this yet it appears to be a Canon fix.

 

Good luck!

 

 

 

 

 

Avatar
click here to view the press release
Announcements