cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MG3620 not showing up on Register Printer screen in LAN setup

cncrame
Apprentice

I am about to throw my printer (Canon Pixma MG3620) out the window. We moved recently and got a new internet provider. I can't for the life of me get the printer connected to the new wifi.

 

I have downloaded the PRINT app on my iPhone. I get as far as step #14. My phone says "Wait for your printer name to appear, and then select your printer." But nothing happens! Someone please help!! Thank you in advance

5 REPLIES 5

srinidhi_ps
Apprentice

Hi, 

I am facing the same issue. Were you able to resolve this ? 

Vickim
Apprentice

I’m posting this reply bc I had the same issue and was able to resolve it. After trying for many hours to add the printer using the cable-less setup method and getting stuck on the register printer screen in the app, I tried the WPS setup and it worked. Basically you push the WiFi button on the printer and let go after you get one orange flash (presumably that lets the printer know you’re trying to do WPS setup). You have then push and hold the WPS button on your router. I held the button for about a minute or so and my printer showed up on the register printer screen. I was able to print from my iPhone. And since the printer was now connected to WiFi I was able to add it on my laptop that uses Windows 10. Hope this helps anyone out there searching for a solution.

so I have TMobile internet and it does not have a WPS button! is that the problem?

Detailed Process:

1. Set printer to WPS pairing mode
Hold
wireless (wifi) button -> power light blinks green -> press BLACK (start) -> press wifi button. The blue light will flash to indicate WPS pairing mode

2. Press
WPS button on router
This varies with each router, but you're looking for a small button either labeled WPS or with a similar wireless icon. There's no need to hold the button as this can potentially reset your router settings.

3. Enjoy the juxtaposition
of relief and frustration at the hours or days of life lost trying to accomplish this menial task. My router connected instantaneously, faster than my tears hit the ground.


Created an account to endorse this solution.
Dumb smart devices drive me insane, and this was a masterclass example.

shadowsports
Legend
Legend

Greetings,

No.  Not a problem.  Many ISP issued devices don't have a WPS button.  

Lets look more closely at the network.  The printer is only capable of connecting to a 2.4Ghz wireless broadcast.  Is your T-Mo gateway dual band?  Meaning does it support 2.4/5G wireless and is it using the same SSID name for both networks?  If so, try temporarily disabling the 5G network and then try connecting the printer again.   

See this link for more information:

iOS

Canon Knowledge Base - Wireless LAN Connection with the Canon PRINT Inkjet / SELPHY App on an iOS De...

Android

Canon Knowledge Base - Set Up a PIXMA or MAXIFY Printer on a Wi-Fi Network From an Android App

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It
Avatar
click here to view the press release
Announcements