cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MG3620 Unable to connect to home Wi-Fi

Flancridd16
Apprentice

I'm at my Whits end with my new mg3620

I really need help. I have looked at so many videos and instruction manuals to connect my new mg3620 printer to my home wifi. I follow the canon installation guidelines. I first tried to connect it through the canon print app. It would search and search, many times making it to the place where I choose my wifi network name, I choose it then it DOESN'T  ask me for my password. It just spins and spins  and then it come up with a heading telling me to wait till my printer is pulled up and it never does. then I start over again/ I turn off the printer/I unplug it and I reboot my router. I then turn on the printer, I press the stop button, then hold the wifi button till the on lamp starts to flash. then I hit the color button once, then the wifi button. it is supposed to be in set up mode.  I find the canon name  on my wifi list I choose it,  Then open the print app. it searches and never finds it I gone over and over this and nothing seems to work, even WPS, HELP ME PLEASE!

1 ACCEPTED SOLUTION

Roy8929
Apprentice

Hello, I had the same problem, it drove me nuts, finally I found the solution for me at least. The Problem is that the printer only connect to 2.4Ghz and the password on your WIFI router has to be in WPA2 only, it doesn't accept WPA3. I have an Arris G34 Router, with the WIFI divided into 5Ghz and 2.4Ghz, both of them with WPA2 and WPA3 Mixed, but I had to change the 2.4Ghz to only WPA2-PSK (AES), when you change the encryption make sure to change the password because otherwise it wont update the encryption change. After this I can keep my phone connected to the 5Ghz and print and scan with the app.  In Windows-11 I didn't use the Canon software, only the default Window-11 printing, For scanning I downloaded the windows Scan Software. I hope this help , if it does let me know. 

Screenshot_20240612_154455_SURFboard Central.jpgScreenshot_20240612_154557_SURFboard Central.jpg

View solution in original post

7 REPLIES 7

shadowsports
Legend
Legend

Greetings,

Please tell us about your Wi-Fi (network hardware).  Brand, model and configuration.

The printer requires a 2.4Ghz broadcast that uses WPA2 / AES encryption.  Does your network meet these requirements?

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks for reaching out.

I have a gigabyte service through Verizon

With their router that will work with this speed. Plus I have an eero mesh system.

Is this the information you'd requested?

 

shadowsports
Legend
Legend

Hi,

I'll reply back shortly.  I already have a good idea what's going on.  Printing tax forms today. 🤣 Fun stuff. 

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

shadowsports
Legend
Legend

Greetings,

Lets get started. 

Please review this thread:

Solved: imageCLASS MF624Cw will not connect to Windows 11 ... - Canon Community

I believe the behavior described is similar  to yours, except you have verizon and eero and he has xFinity and Google Nest.  Please look at my solution.

I asked specifically about your hardware so I might be able to determine your network configuration.  Here is the gist.  Unless your Verizon or eero gateway (one or the other) are put into bridge or pass-through mode, a double NAT is created.

Double NAT occurs when you have two routers on your network performing network address translation.  Only one device should be acting as a firewall between your home network and the outside world (this is NAT), and only one device should be managing devices and assigning IP addresses on your network (this is DHCP).

Unless you have specifically changed device settings on the Verizon device (which is probably a modem/Router) then it is in conflict with the eero or vice versa.

Second consideration.  Newer Eero devices typically come configured with WPA3 encryption enabled as default.  This does not allow backwards compatibility with devices that support WPA2 encryption.  (Your printer in this case), so you must change the encryption on the 2.4Ghz from WPA3 (only) to WPA3/WPA2 in order to allow WPA2 devices to connect.   

Start by confirming the Verizon gateway is in bridge or pass-through mode.  In this configuration the Verizon device acts soley as a modem.  It passes the gigabit connection from the ISP (Verizon) unfiltered to your Eero mesh system.  The mesh system becomes the device responsible for NAT and DHCP. 

Connect all of your devices to it.  The printer has to be connected to its 2.4Ghz broadcast.  Your computer or other devices that support wired ethernet or 5Ghz wireless can connect and communicate with the printer regardless of their connection type or the wireless band they connect to.  

Optional step.  I recommend assigning the printer a static IP on your network.  

After reviewing the other topic, see how it compares to your situation.  Then reply letting us know if you've made progress or have questions.

I suspect you will be in a better situation shortly.  😃

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Roy8929
Apprentice

Hello, I had the same problem, it drove me nuts, finally I found the solution for me at least. The Problem is that the printer only connect to 2.4Ghz and the password on your WIFI router has to be in WPA2 only, it doesn't accept WPA3. I have an Arris G34 Router, with the WIFI divided into 5Ghz and 2.4Ghz, both of them with WPA2 and WPA3 Mixed, but I had to change the 2.4Ghz to only WPA2-PSK (AES), when you change the encryption make sure to change the password because otherwise it wont update the encryption change. After this I can keep my phone connected to the 5Ghz and print and scan with the app.  In Windows-11 I didn't use the Canon software, only the default Window-11 printing, For scanning I downloaded the windows Scan Software. I hope this help , if it does let me know. 

Screenshot_20240612_154455_SURFboard Central.jpgScreenshot_20240612_154557_SURFboard Central.jpg

This was the key I needed. That was exactly the problem! Bless you for your time and effort to help me end this madness I have been going through for months now! Bravo!

shadowsports
Legend
Legend

Worth noting my router is set to WPA3/WPA2 AES and works just fine with my printer connected to the 2.4GHz broadcast.

Most newer EERO routers do come pre-configured with WPA3 only, so it's important that you enable WPA3/WPA2 to ensure backwards  compatibility.  

You may notice I mentioned all of this above.  Glad you figured it out.  Be sure to check you are not in a double NAT configuration

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Announcements