Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX922 goes to sleep and loses WiFi connection


I have a new MX922 that replaced a dead MX870. The old MX870 worked fine until it died but this new MX922 doesn't work correctly on my WiFi network. And the only thing that's changed is the printer (all the other PCs and printers and the Wifi router are the same as before and still work just fine). The new MX922 goes to sleep and can't be woken up from any PC on my network (to print or scan). The old MX870 NEVER had a problem on this WiFI network and NEVER had a problem with sleep mode. I also still have two MX890s that still work just fine. When the MX922 stops responding to pings, the blue WiFi logo on the front is on, and the Network Configuration Page always says "Connection Active" (but it's not).  Any suggestions that it's my router or my PC driver's fault is nonsense. It's clearly a MX922 WiFi bug which Canon needs to fix ASAP.


Over the past few weeks I've discovered that if the printer goes to sleep for an extended period it frequently "loses" it's WiFi connection and nothing I do from my PC will let me print to or scan from it. Basically it stops responding to pings (which tells me that its WiFi network connection is the issue). I usually discover the printer is offline line first thing Monday AM (after the office has been closed all weekend).


When the MX922 goes into a coma the only way I've found to wake it up is to either power-cycle it, or do go into the Device Settings menu and print out the current Network Configuration Page (it sometimes starts printing/scanning again when I exit out of the menus). AND sometimes after waking it up via the menu trick it operates very very slowly (like the Wifi connection is poor or congested) and I end up having to power cycle it to fix it. I shouldn't ever have to power cycle the printer just to wake it up (especially since it probably uses up some ink to recharge the print head each time it powers on).


Since I got it about 6 weeks ago, this printer has gone into a coma about once a week. Recently I tried disabling the Wireless DRX option and that seems to have made it worse. Since I disabled that option, It's gone into a coma 3 times in the past two days.






First thing I did when I bought this printer is assigned a static IP to it.  I always have to turn the printer off and then on again after I send a job to it if it's been idle more that a couple of days.  I'm looking forward to dumping this sorry printer in the near future.  

View solution in original post

110 REPLIES 110

I think I have finally figured this out.   I had this problem and thought it was the MX922 printer itself.   Since I had a lot of ink left, I ordered another MX922.   After installing the new MX922, same problem.... doh!    But it clearly was not my computer or network.


I started looking through my router setup, and noticed that Canon had added specific DHCP entries (how did they get there?).   Even though it looked like the entry was setup correctly, it was the only device specific DHCP entries.  I removed the entry so it would use the default DHCP policies... and voila, no more sleeping MX922.   It's been a few days now, and no more need to power off, etc.   


FYI, I'm using an Airport Extreme, although I imagine they probably write a DHCP lease expiration policy into any router.


Hope this helps.

Can you go into more details as to how you solved your problem. Where did you find those DHCP entries.

Can you elaborate a bit on the DHCP thing?  I'm not a techie, but I'm reasonably intelligent.  I have no idea what your'e talking about, and would really like to solve this connection issue.  A new printer isn't in the budget at the moment, especially since I just bought a load of ink for this printer (that has been working just fine for over a year).  I'm not using a router either, I'm on a wifi hotspot.  Every other device in my house has no problem connecting (they are all apple as well). 

Sorry for the delay in responding.  The configuration I found was in the access control section of my router configuration.   There was a canon entry in the "timed access control" section that indicated the connection shoudl expire after 1 day.  I have no idea how it got there.


Specifically, I found the entry inthe Network tab of my airport extreme configuration.   In that tab, there is an option to enable Access Control (which was checked) and a Timed Access Control configuration.  In the Timed Access Control configuration Canon had added an entry that specified the MX922 was authorized for one day.   The default is unlimited access (no filtering).  When I removed the Canon entry, the problem stopped.


If you have an Airport Extreme, it is specifically in Airport Utility -> Network Tab -> Timed Access Control...

and then remove the Canon entry so it defaults to "Unlimited".


I have no idea why Canon would add a configuration to the router.  It must have occurred as part of the install / discovery process.


Hope this helps, good luck!

Thanks for posting. I, too, am having the same problem -- which I never, ever had before -- and it's driving me mad. I'm all Apple. Followed your suggestion and went into Network on my Time Machine router. My "Timed Access Control" configuration was NOT checked, so I did so. Looking in, all it said was "Unlimited" and I could not find the Canon (or anything else) listed. Not sure if this is the trick but will try. 


Thanks for posting. It looks like I'm going to have to buy another brand printer if this does not work, though. I had zero issues until a couple of weeks ago but cannot run a business this way. I HATE HP but will have to look at them, Epson. If anyone has any suggestions I'd love to hear them. 



I have the fix for Macs. 


1. Go into Finder > Utilities > Airport Utility

2. Select your Router > Click Edit

3. At the top, Click on Network

4. Make sure "Enable Access Control" is ticked, and "Timed Access Control" is to the right. 

For the last two weeks, I have had the exact same probelm all of you have had.   The fix for Macs described by VTBlue seems to have worked.   Thank you so much!  I have wasted so much time working with Canon Support and on my own to get my MX922 to work.  I was just about ready to buy a new printer and, of course, NOT a Canon.   Thanks again!

You're welcome, DGT. Really glad it worked out. I agree with you and njwreckdiver, though: Canon's lack of response is more than concerning, it's downright irresponsible. Despite being a multi-Canon printer purchaser over the years, I will absolutely look at the competition next time around. This type of poor customer service won't be tolerated by me...I have a business to run.

Thank you. finally someone has the correct answer. My problem started when I loaded OS-X El Capitan. Your suggest solved the problem.



If you continue to have difficulties with the connection, please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.