cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MAXIFY GX7021 Software Won't Install

Sol-Adrian
Apprentice

I'm trying to setup a user within my organization to print via a Canon GX7021, I tried downloading the drivers from the Canon website directly, but I'm running into an issue where it prevents me from installing the software due to request of administrator privileges. Even though I am entering an admin account for approval the software throws and error regardless. The user's laptop is on a local domain, the accounts has administrator privileges and I'm connecting the printer via network. The user had the printer connected successfully via the network had no issues up to this point. I tried using alternate admin accounts still no luck.  I provided a screenshot to the exact location where I got the drivers below;

 

Screenshot 2023-10-19 102051.png

2 REPLIES 2

Danny
Moderator
Moderator

Thanks for joining the conversation, Sol-Adrian!

So that the Community can help you better, we need to know exactly which version of Windows is running on the user's computer and whether the network connection is via Ethernet or Wi-Fi. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Sol-Adrian
Apprentice

The user is running on Windows 11 64bit and connected via Wi-Fi. I tried installing the drivers myself on my administrator account as I'm the System Admin. I'm getting the exact error would be providing a screenshot below of the dialog box

.Screenshot 2023-10-19 102919.png

Avatar
click here to view the press release
Announcements