Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageClass MF656CDW Will Not Update Firmware


I recently installed a new MF656CDW.  It is working fine on the network and I can print to it fine. I can also access the remoteUI.  When I tried to update the firmware over the internet it first shows the message "Checking firmware version" for about minute.  It then shows an error "Communication error has occurred.  Cannot check firmware version".  The error log shows no errors.  I could find no documentation on this error and nothing on the internet. There is no reason that my router would be blocking it.   I called support and they had me check several setup settings and all were OK.  They seemed to run out of ideas.  The call was then mysteriously disconnected.  Not happy.  I discovered tonight that I had finger checked the date and time when I was doing the setup.  Once that was fixed the update now works fine.  That's all it was.  Also check your time zone setting. I wanted to post this in hopes that it will help out others with the same problem.



Yep, same here.  I just got printer in early Jan 2024.  Of course, I entered the current date in the printer as 2023 (because that is what you do for the month of Jan...)   Anyhow, fixed the year, and the firmware updated no problem.


Happy that it worked for you.😀