Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon TS3522 scanner not recognized by chromebook


I have a new Canon TS3522 multi-function printer/scanner.  The printer and scanner work great via wifi with Windows, Fedora 39, and Android. On my new chromebook, the printer works fine as well.  I only got the scanner to work once.  The scanner only worked on the chromebook immediately after rebooting after an update.  It has not worked since.  

Settings -> Advanced -> Print and Scan -> Scan, Looking for scanners:  No scanners available.


All devices (2 phones, 3 laptops) are on the same wifi.  Only the chromebook fails to recognize the scanner.

All Canon docs seem to say the same thing, follow the Settings... steps above.  There are no troubleshooting hints.  I tried the Canon on-line chat and they said the only supported O/S are Windows, Android, and Apple.

Can I manually setup the scanner on the chromebook?  

Note, I reported this to Google as a bug as well.