Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Print Studio Pro plug-in can't recognize my Pro-1000 printer driver



Sorry I'm not so tech savvy, so I'm really hoping to get some tech help?

Photoshop updated me to the 2023 version and my Canon Print Studio Pro disappeared from photoshop under the  "automate" tab.  I was able to get it added back on through photoshop support but it seems that the Canon Print Studio Pro plug-in can't find my printer driver anymore so it won't open the program?  I did all the usual updates... I updated my Apple to Ventura 13 and also downloaded the new driver For the Pro-1000 (MacOS 13) update.   

I CAN print to pro-1000 from the regular "print" tab from photoshop, my desktop as well as Canon Professional Print and Layout program but not through Print Studio Pro?  Too bad since so far it's been the best quality for my Art prints. 

After a screen share with Photoshop Customer service, they says it's def a Plug-in error?  Do you think that is the issue also?  How would I even go about addressing this issue? Is anyone else having this issue? 




Thank you so much for your time     



Agreed!!! I use Red River paper also for my prints. I have the Same issue. I still haven’t found resolution. So frustrating.

I’m devastated actually, I had to close my Etsy shop since I can’t produce good prints of my artwork right now.

Adobe tried remotely to fix it and gave up, passing the buck to canon. 🙄🙄🙄

This printer was a big investment for me, I’m definitely regretting it now.

if you find resolution please please please let me know!

PSP has various layout options that can be helpful, but for a straight single image print there is no technical reason why PSP will produce better output than Ps when the Ps settings are correct. Both applications use the Canon printer driver, which does all the work.

I posted a reply to Eric where I just printed perfect output from Ps.

There are some issues on a Mac that can cause problems.

1. when you download and install the printer driver on a Mac it loads it into the operating system.

2. you can't use that printer for printing until you add it via the Printers & Scanners setting in System Preferences or System Settings (depending on macOS version).

3. a frequent problem that develops there is when the "+" add icon is selected the Apple AirPrint version of the printer appears first and folks select that. It is a limited capability driver. It is necessary to wait a few minutes for the IJ Series version of the driver to appear. I've lost count of the number of times I've posted this advice and folks find the printer now performing correctly.

Here is where the issues can develop. PSP is smart enough to find the actual Canon driver in the operating system and use it. But, if the AirPrint version of the printer is what was added, then, when you select a printer in Ps or LrC you will be using the AirPrint driver.

This may not be your problem, but I recommend 1. download and reinstall the latest version of the printer driver from the Canon support site 2. go into Printers & Scanners and delete your current printer and re-add, being sure to wait until the IJ Series driver appears It could take several minutes.

When I first got my printer in 2014 I tried PSP and ran printing tests with PSP and Photoshop and Lightroom. I saw no difference in output, so only printed directly from Ps and Lr. The only time I use PSP now is when someone posts a problem here and I try to see if I can duplicate it to assist them.

I am 100% certain that Ps will produce excellent prints when printing directly from Ps if you set everything up correctly; I just did it two hours ago to confirm.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

View solution in original post



I'm in a similar spot with my Pro-100 with iMac. After upgrading to Ventura, Print Studio Pro no longer appears as a choice in Photoshop. Searching for new versions of PSP, I found 2.2.5 which supports OS up to 12 (Monterey), but nothing for OS 13. I'll try 2.2.5 and see if it works.

In the process,  I've discovered that PRO-100 has been replaced. It looks like the end of the line for PRO-100.

Ohh no what a bummer 😢 I appreciate you responding so I at least know I’m not alone.

That at least helps me narrow it down that my problem  is most likely from  the apple update and not with the photoshop update? 
I’m hoping that canon can fix the OS 13 driver download from their website?   
And hopefully they create a new os13 driver update download for your printer as well!! 😉😅🙏🏽

It's not the OS 13 driver that I think is the problem. It's Canon's Print Studio Pro that doesn't seem to have kept pace with the OS upgrade - possibly because my printer model is obsolete. I've discovered some other Canon updates (driver included) for my printer and OS 13. I'll update them first and then see if the latest Print Studio Pro will work (not likely but worth a try). Will re-post.



We have 2 users who are very MAC centric @jrhoffman75 and @johnmoyer.  I use my MAC for testing work applications.  All of my camera stuff is done in windows.  

John Hoffman is particularly strong with Canon Professional printers, Lr, and PSP.  I'll let him know about your post.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I just checked (MacBook Air-Ventura OS).

PSP works w/LrC, but I have same experience w/Ps. Copied plugin folder from Ps 2022 to Ps 2023. Does not show up in Automate.

Update - when I checked last night all I did was start up PSP. Based on a different post I just saw I redid my test and tried to print. I did get the memory error pop up. 

It doesn’t help me with Pro-100, but Pro-1000 printers can use Professional Print & Layout. 

Since PP&L and PSP both use the Canon driver I’’m not sure why PSP gives better prints. Maybe a settings difference?

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Cool, Thank you for trying that out.

Do you think this is this something I should I try to contact canon customer service to fix?  

@artgirl303 wrote:

Cool, Thank you for trying that out.

Do you think this is this something I should I try to contact canon customer service to fix?  

See my updated post above. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Yes that is so strange how PSP prints better?  I can print from professional print and layout too but the colors are pretty off? Ugh 😩 I run a small art business with my printer so I’m really stressed on what to do? 😥

 I tried to go back and use photoshop 22 version after the Ventura update but PSP isn’t  working from that old version anymore either? 
I’m so sorry to bother you, I really appreciate your help 🙏🏽
I may just have to take a deep dive into the settings of PP&L to get the prints made? 
thank youuu ☺️

Glad to try and help. 

There is a third party printer plugin called Qimage One from Binartim Software. It has a free trial. You might see how that works. They have an active FB presence so you could post problems if it doesn’t work for you. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic