Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot register PIXMA TS3322 on Canon Print app


For the past week i have been unable to print from my canon print app on my iphone that for the past years has worked with no issue. At first it was saying the printer was not connected to wifi and i was struggling with that but now i know it’s connected as i’ve gone through the setup process soooo many times. I  do everything just fine but when i get to the “register printer” screen no matter how long i wait the printer name will not appear. And then i just get taken through the whole process again. what do i do????? 



Thanks for joining the conversation, aa7!

So that the Community can help you better, we need to know exactly which version of iOS is running on your iPhone. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

My iphone is updated to the latest ios 17.3.1 and so is my canon print app. 

Product Expert
Product Expert


If you have removed and reinstall the app but the printer is still not detected,  I recommend reaching out to Canon support. You will need to register your Canon gear HERE to access additional support options.

We look forward to hearing from you.