Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't Open Images in Canon Professional Print and Layout Software


Does anybody have any magic for me?

My images will not open in Professional Print and Layout Software 1.3.0 (Windows 10 64-bit). I have tried to drag-n-drop them and I've tried using File>Open but I get the same result... nothing. The images (JPG, TIFF, etc.) will not load and I get no error message.

The problem seems to be related to Photoshop Elements (19.0). I am able to get other images to open, but the images that won't open have been edited and saved in Photoshop Elements.

I have tried printing with the PPL plugin for Photoshop Elements and I get a unspecific printing error, so that doesn't work either. Honesty, I'd prefer to print directly from Professional Print and Layout, but again, the files won't load.

If I read a problem file in to Paint and save it, PPL will then open it. Seems like I will lose lots of picture information doing that though.

Very frustrating. If PPL gave me an error code or message about why the file won't load, I could at least do some more troubleshooting.



Product Expert
Product Expert


I recommend reaching out to Canon support for this issue. You will need to register your Canon gear HERE to access additional support options.

We look forward to hearing from you. 


Excuse my bluntness but honestly, I can't believe that users spend thousands of pounds on kit and you can't get the basic software to work properly.  I've also tried to log on to a new account with and generate a ticket and now that doesn't work either.  I actually need the stupid printer to work now.  Not tomorrow, or in a few days time.

Welcome to the Canon Forums!

The Forums aren't intended for immediate assistance. If your question is of an urgent nature, click HERE to visit your My Canon Account to discover your personalized support options.

If you're outside the USA, please click HERE to find your support options. 


I had the same issue with one tiff file opening, and another not, and I figured out it's because the one that did open was in RGB Color Mode, and the one that didn't open was in CMYK. Once I changed the CMYK file to RGB and saved it, it opened in PLL.

Hope that helps!

Thanks, djpassion. That is the fix. It appears that most "test" images in black and white that are out there on the web are in CMYK and need to be converted.