Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't Enter Password on PIXMA TS9020


I have a ts9020 canon printer. i got a new wifi router + network. tried to connect my printer to the new wifi, won't work. 

when i do a manual connection, it doesnt let me enter a password at all. it just automatcially starts connecting and fails. when i connect to a different wifi, it lets me enter a password. its only my wifi that wont let me enter a password.

i tried resetting all settings and it still doesnt work. i tried setting it up with the app from my phone (android) and it still doesnt work. it gave me an error code, 3441, and said it wouldn't connect. i followed the youtube official tutorial too. its been like this for MONTHS and im so tired of it... PLEASE help me i dont wanna get a new printer



Lets see if we can help.

You'll need the Print Inkjet / Selphy App

Canon PRINT Inkjet/SELPHY - Apps on Google Play

Now follow the steps here:

Canon Knowledge Base - Starting Easy Wireless connect on the TS9020


The printer has a 2.4Ghz radio.  It can only connect to a 2.4Ghz broadcast.  If your router is dual or tri-band and is using the same SSID name for all broadcasts, this can cause issues when attempting to make a connection.  Its often helpful to use separate SSID names for each band, or temporarily disable the 5G network while making the connection.  Example my router has 3 bands, with 3 different network names.


Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It