Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575


By clicking the "repair request" link in the response email I received from Canon, it seems that it costs a minimum of $160(!!) to send the camera in for repair.   I did not investigate further, so potentially it could cost more to fix this specific shutter issue.


Given that price, the price of new camera and my need for a replacement camera, I ended buying a new camera ... I was tempted to go with the S110, but, frankly, I am concerned about reliability.


While Canon states this is not a known issue, it seems that this is more than a random occurrence  ... especially as I have to think that the few posters here are a small number of the owners experiencing this problem.


I remain hopeful that Canon will do the right thing here and offer to repair the camera for no cost/nominal cost ... hint, hint.



Hi, my S100 shutter most of the time doesnt work ! I lived in tropical country with high humidity level. The only time will it work properly when I took it out of the Dry Box ..( work for 30 minutes or so ! )
The warranty are far out of date! I can believe that i need pay for the s100 to be repaired for such a considered new camera
Before I submit my camera for repair , is there any way I can do to fix it my self ?

Hi wailan!

Welcome to The Canon Forums, and thank you for your inquiry! We appreciate your participation, however we need to let you know that the Canon Forum is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market. If you live outside the United States, please click here and select your country or region for your support needs. Feel free to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA.

I am having the same problem with S100. After the great performance of S90, I thought I'd continue with the series but I am totally dissapointed with the quality. I have to press the shutter button for a few seconds and really hard before the shutter goes off. After a few patient trials, the camera is pretty much useless.

Unfortunately, I am just outside the warranty period.

Same thing happened to me. After resetting to factory standards it still does it. It seems to want to cycle between the regular display and one I have not seen before with the shaky hand figure and "60" at the bottom. This is in all settings. I usually shoot raw and program or t value. I can get it to work by pressing the shutter, releasing, and pressing again. Watch the display. If you only have writing at the bottom it won't work. If you press again, it will cycle back to the regular display and take the picture. Very frustrating! I missed a lot good shots on my last vacation trying to figure this out. It is still not fixed but this seems like a work around. Canon... Step up and find a fix. We love your cameras.


I have the same problem too.


I tried pressing the button in different angle with A LOT of pressure, the camera will focus fine but shutter will not fire.


Occasionally it does but it is certainly not nomral and it indicates probably contact problems within the button.


I am based in Hong Kong, but I do not think humidity is the problem, or else none of the other cameras will work, right?


EDIT: Camera was repaired by the HK Canon centre at a costs of about USD80.  I would hestitate to buy another Canon product, seeing the S90 S95 S100 S110 S120 series is being released so quickly consecutively...sounds fishy imo.



Same problem here, less than a year with this camara and now i am in the middle of my vacations! So what options do I have, i am even thinking on buying a new one maybe the S110 but i am not sure with this experince!...thanks canon!


I registered to this forum just to share my experience with my Canon S100.  I bought my S100 in March of 2012.  It started exhibiting the same shutter release problem where I press down on the shutter button, but the shutter does not release.  Yes, I know you need to press halfway then press fully to release the shutter... that is not the issue.  I press halfway for focus, then I press all the way down and the information text on the LCD goes away, but no picture is taken.  It's like the camera is hesitating to do something.  Sometimes it takes the picture, like 5-10 seconds later.  Most of the time it doesn't take the picture at all.  It's maybe a 25% success rate of actually taking the picture when I want it to.


I sent it back to Canon under warrantee, and they repaired and sent it back to me.  Repair bill says they replaced the entire lens assembly.  But, the issue was not fixed and my camera still had the shutter problem.  I sent it back again, then they sent it back saying they could not reproduce the issue.  I call Canon and they say to send it back again which I do, then I get it back and the top assembly was replaced.  STILL DID NOT FIX THE ISSUE.   Now my camera is out of warrantee and I have a useless camera which cannot take pictures.  I paid $400 for this camera and I am not happy that the issue was never fixed.


I am having this same problem.  It is obviously a defect in the camera,  Is Cannon offering a free fix?  The camera is now useless.  


I bought this camera in the US. However, I was living in Thailand for the last year when this issue came up for me. Not wanting to deal with international mail issues, I chose to forego my still active warrantee in the US and send it to Canon Thailand.


It took a week and about $50 to fix the problem.


My Thai is not technical enough to understand the exact issue, though with the return of my perfectly functioning camera, I was also given a thin piece of circuitry that clearly ran along the top of the camera near/under the shutter release button, that I would assume connects it to the shutter mechanism itself. I haven't had a problem with it since, and this was around 4+ months ago.


It seems that Canon US does not have an interest in being accountable for their own responsibility in the matter. I hope that everyone in this forum, in addition to the likely high volume of others who have not posted here, are able to find a solution.