cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100

sandysorlien
Apprentice

Hello,

I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Hi Argh
Just put the first two digits of the serial number, not the whole thing, as there is moderator concern that the camera and/or purchaser can be traced.
Recording these two digits is just a quick way to emphasize to Canon that the problem is not restricted to the small sample series they have listed online.
Thanks and good luck.
I am still working with the ziplock bag of desiccant packets. As long as I am doing short photography sessions and I remember to replace the camera in the bag it works fine.

Thanks AngelaX.  I'll make a note of that RE: the serial numbers.

 

We paid a $425 or so about 2 years ago since the S100 had good reviews so we could use the camera for business.  And, we had good success with previous Canon cameras.  This, supposedly, is a premium camera, but not the shutter release.  Is this planned obsolescence? Maybe next time I scan the forum boards for refurbs.  

 

https://en.wikipedia.org/wiki/Obsolescence

Obsolescence is the state of being which occurs when an object, service, or practice is no longer wanted even though it may still be in good working order. Obsolescence frequently occurs because a replacement has become available that has, in sum, more advantages than the inconvenience related to repurchasing the replacement. Obsolete refers to something that is already disused or discarded, or antiquated.[1]Typically, obsolescence is preceded by a gradual decline in popularity.

rbarribeau
Contributor

Wow, I can’t believe this is still going on!  I’m the guy who posted the original DeoxIT fix (post # 186) back last year.  I just happened back on the forum to look up something for my 5d, and came across this thread again.  Figured I’d post an update – my S100 is still working fine after using the DeoxIT back last November.  Have probably taken about 800-1000 pictures since then (maybe more, I’m too lazy to actually go get the camera and check), it’s been out in the rain, the kids have dropped it in the snow, etc.,  and not a single glitch.  Hoping that continues…

Rbarribeau, your Deoxit fix was a great tip. It worked for me for a couple of weeks, but for most of us it was temporary. While I was at it I used the deoxit on the zoom control of another camera. That fix is still good. You might want to hedge your bet by investing $18 to have the part on hand. It may not be available forever.

Argh
Contributor

Thanks everyone for the tips and help.  

 

I'll see what Canon says.  It seems to be known problem (at least the shutter issue), but who knows.  I will say that this problem with this camera has made me think twice about this company.  I'm sure there are other companies out there who have better customer support..Samsung, Nikon?  Pentax??  What's a good option to replace this S100?

 

Thanks.

s2luminous
Apprentice

So I ordered two new parts and neither of them worked, and I'm positive the piece was pushed in all the way... The camera no longer turns on 😞 I even tried putting the old strip back, but it still wouldn't power on.

The one thing I noticed was that the original piece was labeled CM1-7226-020, and that the newer parts were CM1-7226-030 (20 vs 30). When I ordered the part I simply ordered CM1-7226-000. Can anyone comfirm what parts they exchanged? I noticed a slight difference in the pins on the strip, but I have no idea if that makes a difference and I'm just looking for confirmation bias...

Allegedly that is the right part number you requested, see page 34 of this thread about half way down also on pages 31, 32. I did not see anyone mention a difference in the number they ordered to what they received.

Maybe I missed that post where they got a differnt part number and it still worked.

Being that you ordered a 000 and your existing board was a 020 and they sent a 030 my gut feeling is they sent you the wrong parts.

 

Wait to see who else chimes in but you may have gotten the wrong parts. In the meantime you can call Canon and confirm they sent you the right parts. I assume you got them from Canon ?

I ordered with the number ending in 000, and that is what they confirmed by email.

CM1-7226-000        FPC ASS'Y, TOP       

That  is what is on the original part. 

However, when I called to place the order, and gave that part number, I still had to have a conversation with the representative about which s100 I have. There is another S100 that came out about 12 years ago-- part of the "elf" series. One distinguishing characteristic is mine has a pop-up flash, and the older model does not. I cannot confirm what part number was actually delivered without taking the camera apart -- and since surgery always involves risk of fatality I don't want to do that. I suggest calling Canon repair parts  (866-481-2569, 9am-7pm eastern) and having that conversation about the various part numbers. If it is their error they may make good.

 

Of course it would make sense for there to be a newer version, since the orginal seems to be prone to failure. On the other hand, Canon denies any fault with the original, so perhaps a different number reflects a different manufacturing run. But a design change would be illogical unless there is a known problem. So far at least two people on the forum have reported the camera failing to power on after replacement, and in one case more wiggling got it working. But don't force, just wiggle. And make sure that the brass button that winds up under the power switch is clean.

 

Isn't Canon clever to assign the same model number to completely different models?

yeah Dan there is a silver S100 Elph model that I see out there too. And you may have gotten a Canon rep who knew what he was doing and needed to ask you to get you the right part.

lol 2 different cameras same model number...maybe they saved money that way

Yeah, and then two (or 3) different numbers for same repair part. No tale too strange to believe.
Avatar
click here to view the gallery
Announcements