Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Thank you. Helpful to know.

This is the same piece I ended up buying, the shutter switch on the left of the picture has faulty solder joints causing intermittant failure to connect. I haven't fitted mine yet though.

The suspense is killing us. Go fix your camera!

Dan, I tend to be on the lazy side, so while I have worked out how to manipulate it so it works, I tend to put it off 🙂
I used it today as a matter of fact.

If you were really lazy you would just spray with Deoxit and be done.

Also in regards to lazy once you have opened the camera up drill a hole in the center of the shutter realeas button just slightly larger than the straw that comes with the Deoxit. That way when you put it back together and should the problem retturn you need not take it apart again to spray the switch..just insert the straw in the hole you drilled. You can cover the hole with a small round stick on pad to keep it sealed in the meantime. Those pads are available at office supply stores as well as hardware stores in different materials.

Good idea about the hole. I will wait and see if it ever relapses before implementing it. Maybe Canon should put the hole in at the factory.

lol yeah or maybe Canon should have purchased higher quality switches that should not fail so soon !

...or noticed 30 pages of the same complaint and made good.

Ha! I have been viewing this as a battle of wits between me and the camera and I want to force it to work without much effort on my part 🙂
Enter for a chance to win