Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Angela: Thanks for confirming. Then **bleep**, maybe only SocalJD lucked out and only had to give the S100 one good puff.

Perhaps I'll have someone else, uh, puff the S100. That may bring, different, results.

Really? Really?! "**bleep**" is the censory word?

For those curious, it was the alternative word to "Darn"

Interesting....mine only works in dry conditions. Hence, the desiccant.
One more try with customer service, then it is the BBB.

yes I dont think we have that "ah ha !! " moment yet since the reported fixes are pretty diverse . There may be more than one fly in the oinment

Hello Everyone. Just another Canon S100 user here with the same Shuttler Delay problem. Sometimes it takes 2 to 5 seconds to fire and sometimes it just doesn't fire at all. I'll be calling Canon's Support and see what they are willing to do. If they start to claim they are unaware of this issue or tell me they're going to charge me then I'll just do as others have suggested here and go to the BBB. I don't have a lot of time to waste around with poor support. This issue has been plauging users since at least 2013 and I guarantee that most people don't have the patience to post here or try the cannon support and just throw the camera away and get a new one. I can only imagine how many people we don't know about that are/were affected by this issue. Time for cannon to issue a recall on the shutter delay problem. I might understand if this was one of their cheaper throw away cameras but this is supposed to be a premium camera with a premium price! Makes me very reluctant to get another canon, especially with all the choices we have these days. I will say this though. If Canon does the right thing then I will be the first to come back and post and give the cudos for taking care of the issue. I'm happy to give credit where credit is due. We'll see.


By the way my Serial Number is 442032003451



Let us know how it goes. I still couldn't resolve mine even after trying to huff into the camera as suggested by some members above. It worked for a few seconds then it just became as dead as ever....

If this solution works for you don't forget to give this user socaljd a kudos!!! I gave you a kudos , socaljd. You rock...

You should email CANON and get some canon credits or something for finding a solution. I will back you up on this and I'm sure so would other users. You at least found some sort of solution that may work and that's really helping canon out too. They'd be pleased!

This is hilarious. Now I have to dig out my camera -in-a-bag. Gave up on it. I will definitely give it a try - nothing to lose -whenI find the camera...
Does anyone have an explanation?

Angela I gave it my best guess, by blowing hard into those ports it pops the flexible circuit board back into place so that the shutter button can activate the release switch again.

Then theres a humidity guess, introducing the humidity from your breath does something.


08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5