Showing results for 
Show  only  | Search instead for 
Did you mean: 

SX60 not generating an SSID


I purchased a used SX60 in very good condition but cannot get it to connect to anything. First, I reset everything to default. I set up a nickname for the camera. After downloading the app, upon pressing the phone button, I get two icons, one for a phone and one for a computer. I select the phone. A screen appears which says "searching for access points" and then almost immediately I get a "connection failed" notification. I've tried this multiple times, tried changing the wifi settings (which are very few). The MAC address shows nothing but a series of F's. Am I doing something wrong, or is the camera unable to generate a hot spot (which is what it appears). 


Yes it is pretty simple to do and if you have the option to return/exchange it you should do that. The firmware may be corrupted

View solution in original post



And you have a memory card in the camera? I think you need that for any connections but not sure if that would prevent the camera from showing an SSID

Yes. Have a memory card, in the display mode. There is a brief flash of a screen that lasts less than a second before I get the error message. 

That's not good and your right there are few WiFi settings and as far as I can tell the camera should just generate its own SSID without you doing anything else.

That's pretty much what I figured. I have a Sony a6000 so I've done this before. Just when it should go to the screen that shows the SSID, it flashes on a screen very briefly then goes to the error message. I also tried to connect it to my home wifi and after entering the password I got the same error message. May need to return this one. I thought I might be missing something obious but that's not evident after going through all the menus and documentation. 

Yes it is pretty simple to do and if you have the option to return/exchange it you should do that. The firmware may be corrupted

I assume there's no way to update the firmware?

I do not think so but I was wondering if you reset the WiFi settings to default thru the WiFi menu? The global reset to defaults does not reset the WiFi settings

Did it twice...had to rename the device but otherwise no change. 

Well then the only other options you have is to see if someone else here comes up with something or contact Canon and see if they can help and at what cost or return the camera. Sorry I couldn't help you

08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5