Showing results for 
Show  only  | Search instead for 
Did you mean: 

PowerShot G7 X Mark III Flash won't work


   I'm very much curious on why the flash won't work on the gx7 mark iii. I tried to use it on auto and SCN, it works fine . However, when I turn the flash on the M, P, TV... the flash won't work and I can't seem to find the setting for keeping the flash on . So is there any solution or setting to turn the flash on , on manual? Or the flash won't work on these settings?



You use the buttons on the back:


You can also change the settings:


There are some more settings, this is just for an example


I have the exact same problem in my G7X Mark III. When M mode is active, pressing the right arrow in the wheel won't show any option (as @kvbarkley was suggesting). I have checked the flash options in the menu, it's correctly set in manual so it should work... Could anyone please give any suggestions? Thanks a lot!

I have a new update on this, I was able to unlock it! The thing is that flash won't work in M mode only where you are using electronic shutter. Change it to mechanic and it should work just fine. Try it and let me now.

As usual, it is in the manual:



Yes, and yet your answer did not help Nicole or me at all. Thanks anyway for it!

So easy to answer that, of course every problem can be solved by checking carefully the manual...

My first answer was useless, the second answer is another page in the manual.

My point is simply that it is documented and not a bug.