Showing results for 
Show  only  | Search instead for 
Did you mean: 

PowerShot A720 IS “change battery” issue


Hello! My parents recently bought me a Canon Powershot A7120 IS from Ebay and it had been working perfectly fine for the past month but recently it keeps flashing the red battery sign and when I try to take a picture the screen turns black and says “change batteries” I have tried pretty much everything. I changed the AA batteries multiple times, even went out and bought the smaller battery CR1220. No matter what it shows the same thing and it also resets the data every time i turn the camera on. please please help what can i do??



You mean A720, not 7120, right?

The little CR1220 battery powers the clock when the AAs are taken out or run down. That's all. There's no warning for it other than the camera tells you to set the date &time when you turn it on.

What AA batteries are you using? Have you tried brand-new alkalines? Or lithiums?  Rechargeable batteries are not liked by some cameras. They are lower voltage than alkalines and lithiums.

This is a 16-year old camera that I hope didn't cost much.