cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

POWER SHOT SX720 HD Will Not Connect with New Computer

stealthpaws
Contributor

Hello to everyone. I hope I'm not the only one who's had this issue.

PowerShot SX720 HD was set up on my old laptop when it was new.  At that time, the service called Image Transfer Utility directed you to something called "Image Gateway".  It now is defunct, and you're directed to a different site.  It does NOT allow a new camera to be added to the list.  Well, I finally had to buy a new laptop.  I downloaded the software from the Canon site, installed it, did the wireless set up using the tool provided, and ... no matter WHAT I do, the camera will NOT connect.  The icon in the system tray refuses to allow me to add a camera without signing into Image Transfer Utility, which, as I mentioned, NO LONGER WORKS.  

Yes, I've tried disabling my firewall/virus software completely.  I've also added the Canon software to "trusted" and "super trusted" within that software, and it's useless.  The camera "SEES" the computer, but can not actually connect with it.  There does not seem to be a way to circumvent the Image Transfer Utililty.  I really need my camera set up.  I use it to photograph my jewelry, from a different room, and...I don't even have a cable.  

Thanks for anyone's help.

The prompt when you try to add a cameraThe prompt when you try to add a cameraWhat you get when you log inWhat you get when you log in

7 REPLIES 7

stealthpaws
Contributor

I should have mentioned, old & new computers are Windows 10 home 64 bit, basically identical.  Same ZA virus software, etc.  

stealthpaws
Contributor

Next, I tried creating a new Canon ID.  It says I have to register my camera as a "first time user".  It takes you to the page where you pick your camera, and then asks you to use the wifi button to connect, using the cloud icon on the camera screen.  I hit the cloud button, and it says "Web service settings unchanged.  Change the settings on a Web browser and reconnect"  Change WHAT settings on WHAT web browser?  It just continues to send photos to my old account.

I've never been so frustrated with a service as I am with this mess.  

BergensMom
Contributor

Hey!  I'm sorry about the frustration - I was having the same issues with my Powershot and my Mac.  Here is what I found to do that worked for me: 

1.  Finally figured out that I should go to https://image.canon/st/en/index.html (as the Image Transfer Software is out of date and takes to you the screen you posted.)
2.  Walked through the steps to connect my camera (simple enough - put your camera on wifi, put in your email to verify your account, etc. but time consuming)
3.  Selected the little Cloud with a Camera icon on my camera.  
4.  Selected on my laptop that I wanted to also upload to Google Photos.
5.  Little green light on camera started flickering and the pics started rolling in to the ihub.image.canon website as well as my Google Photos. (Pics are only on ihub for 30 days, is says)
6.  Downloaded ALL pics from ihub to my laptop.  They arrived in two zip drives and open in Preview.  

I hope this works for you!  

Hiya...thanks for answering!  I got hooked up to the cloud service, and yes, they automatically d/l, but I want to connect directly to the computer as opposed to going through the web svc.  It's the way it is supposed to work.

I totally get it - that's what I wanted to!!  But, at least this workaround got me to the end result I wanted.  

Glad it worked out for you! And now people reading this post will have a solution, even if it's not the best one.  

Hazel_T
Product Expert
Product Expert

Hello stealthpaws,

The PowerShot SX720 HS is no longer able to connect to a Windows 10 computer through the Image Transfer Utility. Our PowerShot phone support team are able to assist you with connecting your camera and Windows computer using a different method. They are available at 1-800-652-2666 from 9 a.m. to 9 p.m. Eastern time Monday through Friday.

Thanks

Hazel

This only works if I'm willing to pay for help on a product which is no longer functioning as it was designed to, not for a problem I created, but for Canon's lack of caring about supporting their products as they were designed to function.  I didn't break it.  Canon did, and this makes me very angry.  VERY.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.