cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

New PowerShot SX720 HS won't power on

bobmclimans
Apprentice

New camera will not power on, using the battery that came with the camera, and yes it is fully charged and properly inserted.  What next?  Send it back?

2 REPLIES 2

John_
Authority

Absolutely send it back! 

rbtl
Apprentice

I also have a PowerShot SX720 HS that’s a few years old. It had salt water damage while kayaking recently in French Bay, Bar Harbor Maine. When we got home, I was too impatient, took out the battery, SD card, and I hit the power button. No go. Googled extensively on ways to save it: put it in a big plastic to dry with container filled with silica to absorb water. Let it air out a couple of days and tried again. Still no go. Then I tried cleaning the battery contacts with rubbing alcohol and thin Q-tip swabs. Did that 2x or 3x. Funny, a couple of days later, as John mentioned before, I tried the Play button, and it turned on! Hit the shutter button, and lens expanded it. However, the Power button still didn’t work.

I was about to give up and called Canon’s repair service center. The tech said Canon doesn’t service the PowerShot SX720 HS anymore! He suggested an upgrade to a refurb SX730 or SX740 which will still run me a few hundred including free shipping. It’s a lot more expensive than the SX720. I was debating whether I should bite the bullet and buy another one. I really like my SX720, and it’s only a few years old.
I’m glad I didn’t give in.

And as mentioned before, I tried John’s suggestion: try carefully spraying into the seams of the power switch. Instead of Deoxit D5, this time I purchased a spray can of isopropyl alcohol (forgot brand) at MicroCenter which is used to clean out sensitive electrical connections, pc components, circuit boards, etc. Googled it, and read good reviews about and it’s not as expensive as Deoxit D5. At Home Depot, even WD40 has its own version of contact cleaner. So I gave it a shot. Power button still didn’t work until the 3rd time today. The Power button works now! John was right about the Power button. Apparently, the electrical button under the mechanical Power button was probably stuck until the isopropyl alcohol un-stuck it.

So Folks, before you decide to give up, spray the Power button like crazy! Press the Power button for a few minutes to let the alcohol seep in. Spray again, repeat. Have patience, and you’ll be doing the happy dance! Good luck!

Avatar
click here to view the gallery
Announcements