Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera flashes when charged battery is inserted. Won't power up.


Battery went dead while taking photos. I charged the battery. Upon inserting, the camera flashed (weird) but wouldn't power up. Then, the battery charger showed that the battery needed charging, so I did it again. In a few minutes it appeared to be ready, so I repeated the process with the same result. I thought maybe I ruined the battery, so I bought a new one.

Same result. I would think it's a software problem, but there's nothing I can do to get this **bleep** thing to light up!

Any ideas?



Hi JimE!

We understand your frustration, and we're here to help!  To have a better understanding of your issue, please let everyone know which model Canon camera you own.  Also, please confirm with us the exact battery model, as some of our cameras have additional battery options.  That way, our Canon Forum members and our Subject Matter Experts will be able to assist you with suggestions appropriate for your model.


And here's some additional suggestions regarding the battery issue you've described:  do you have an extra battery charger?  If you plug your battery charger into a different outlet, does the same issue occur?

We hope this helps, and look forward to working with you!


The model is Canon PowerShot SD 980 IS

Product Expert
Product Expert

Hi JimE,


Unfortunately, based on your description, your camera will require service to correct this issue.  For service options, please click here.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
click here to view the gallery