cancel
Showing results for 
Search instead for 
Did you mean: 

Camera Window gone with new ImageBrowser EX update?

Kkay
Contributor

I recently deleted the old ImageBrowser EX, and installed the new one.  Camera Window worked, but it didn't work very good after the previous update.  At least I could upload the photos, but could not use ImageBrowser EX.  Microsoft put out a new update, and then I couldn't open the Camera Window anymore.  I thought that Microsoft was not recognizing the camera at all.  So I deleted the software, and reinstalled it, this time with the newer update from November 2014.  Now ImageBrowser EX will open.  Before it would have a place letting you click Connect To Camera.  Now you don't even see that, or the Camera Window.  If I try to import images from memory card (since that was my only real option) it says No Images To Download To The Memory Card.  I know Canon can see the camera, because I had to connect via the usb cord, with my camera on. 

 

I have deleted and reinstalled 3 times.  If I go to the Canon site, it says I don't need a driver.  I finally found Device Manager that showed under portable device, my camera.  It has an MTP USB device driver for it.  But it is giving me error code 37.  I have tried to update it, but it says there isn't a better alternative.  Nothing is working.  I deleted the driver, and software all over again, and reinstalled.  It still is like before.  Any suggestions?  I think Canon should make a driver for this situation.  But until then, I don't know what to do.

 

Oh, and I did pull  the cdrom back out, searching for a driver there, but couldn't find one. 

4 REPLIES 4

Tiffany
Moderator
Moderator

Hi Khay!

So that the Community can help you better, we will need to know which camera you're using.  Any other details you'd like to give will help the Community better understand your issue!


If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at http://bit.ly/EmailCanonor by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 8 AM and 8 PM ET (5 AM to 5 PM PT).

Thanks and have a great day!

I have the PowerShot SX120 IS camera. I am using Win8.1  (upgraded from Win8)  I have a 64bit Dell computer.  Thank you~!

Mykolas
Authority

Kkay,

 

The Code 37 in the device manager means Windows could not initialize the driver for the camera.  The driver for the camera is a driver built into Windows by Microsoft.  This same driver works for many other cameras as well, not just your PowerShot SX120 IS.  When you see this code, Microsoft recommends uninstalling the driver, then reinstalling it.  Since you have done that and still see the error, I recommend that you contact Microsoft directly to get them to help you restore the driver to working condition.

 

I am also curious if you have any other hardware connected to the computer, USB or otherwise, as well as if this computer is a laptop or a desktop.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

My computer is a desktop.  I thought all camera makers had their own drivers.  I have a usb wireless mouse, and a wired keyboard.  I also have two speakers hooked up.  I also have a wired mouse hooked up. Plus the modem is hooked up too. I also have a printer hooked up.  This has been the same since I got this computer, for quite a while. 

Announcements