cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

usb connection error with Cannon printer lpb6000

jamesd1
Contributor

Using the Cannon software driver downloads, I've tried a half-dozen times to install this usb printer on my Windows 10 64bit system.  It says it installs and shows up in the devices, but attempts to print gives "connection error" with no other info.  I notice that on installing it only shows one USB option of usb1.

Tried uninstalling, restarting Windows  plunging and unplugging power to the printer and disconnecting/reconnecting USB cable as advised in trouble shooting; nothing works.

2 REPLIES 2

SamanthaW
Moderator
Moderator

Hi there,

It looks like the imageCLASS LBP6000 has been retired, which means support from Canon USA directly is no longer available. The Canon Community may be able to offer suggestions though! 

You can also speak with a Canon Upgrade Program specialist to see what your options might be to help get you into a discounted current-generation printer that would be compatible with your current needs. They're at 866-443-8002.

Thanks but not a good solution for my Windows 10 Pro system.  After many additional fails, I tried installing the printer on my wife's Windows 10 Home and it installed with out a problem.  So the issue is with my Windows system.

Avatar
click here to view the gallery
Announcements