Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS MF644Cdw Can't uninstall Canon driver -- "other Canon drivers are using the files."


Please help.

Bottom line Windows is unable to uninstall the Canon driver "Canon MF642C/643C/644C" because a Canon Generic Plus UFR II V120 (x64) is in use.

The whole story is a long convoluted mess, but basically my wife's laptop wasn't printing to our Canon MF644C printer. I removed the previous driver and installed a new one through Printers and devices, but it couldn't print a test page. I downloaded and installed the canon driver but it couldn't print a test page either. I tried to uninstall both and one uninstalled and the other will not. I've rebooted and still get the same error. The print driver is removed but in the Printer server properties on Windows under the Ports tab I cannot delete the Canon MFNP port. Also, under the drivers tab I cannot delete the Canon Generic Plus UFR II V120 driver.

I tried to pint the printer's fixed IP address from her laptop and get "Destination host unreachable". HOWEVER, if I ping from my laptop it ping's just fine and I can print OK (after restarting the printer)

The first step is how to uninstall when I get the "driver in use" message.image.pngimage (1).png




Start here:

Settings > Control Panel > Device and Printers

Right-Click on the Canon 644C. Select Remove Device from the context menu.


Printer gone. Now select (right-click) another printing destination. One Note, Print to PDF, or XPS are examples. Select Printer Properties. Press the Change Properties button.


This will unlock the ports tab and allow you to remove interfaces.


Important. After you have deleted the port with the Canon 644C designation, you must select another port for the existing device before you can save it. If its the PDF or XPS, just select appropriately. Then Apply and OK to close. Now try uninstalling the software again from the Programs and Features applet.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks for the guidance, shadowsports .

My problem is that I cannot delete the port even after following your instructions.  I'm guessing that the process has changed somewhat in windows 11.

This is keeping me from using any of the Canon software, as it times out, not finding the device (since it's looking at the wrong port).  Simple printnig does work, I'm guessing because it bypasses the software and its faulty port designation.

Cannon tech support is apparently closed for the weekend, and I am supposed to scan a document before leaving the state for two weeks.  Any guidence you or others can offer on getting this port deleted, so that the software can be uninstalled and reinstalled correctly, would be most appreciated!