Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ventura 13.4.1 (c) won't print consistently to MF644CdW


I updated my M1 Macbook to Ventura 13.4.1 (c) (22F770820d) and printing stopped working.

I can scan, & I can copy, but I can't print. Even a test page sits in the queue and says "Ready to print". Nothing in the error log. If I pause the job in the queue, the error log says "Job held by [my name]". Unpausing the job does nothing & no new entry in the error log. I am using the latest printer driver (10.19.14).

I’ve rebooted my laptop; I’ve turned the printer off & on; I’ve turned it off & removed the main power cord, waited 10 seconds then put it back in & turned the printer back on; I’ve removed the printer from System Settings; I’ve reset the print system; I’ve uninstalled all printer & scanner software & removed all printer entries in the plist files; I’ve downloaded and reinstalled the scan & print drivers & readded the printer. No joy. I can scan and copy, but not print.

I am incredibly frustrated right now.

Please help.

PS. this just happened: I rebooted my laptop with 2 jobs sitting in the print queue: one was the test page mentioned above, the other a 2 page PDF, both of which had been sitting in the print queue for 45 minutes. When my laptop restarted, the test page actually printed, but the PDF said “Printing -- connected to printer” and did nothing. So I restarted again. Now the PDF job in the queue says “Printing -- unable to cancel print job” and the error log says "unable to cancel print job" too.

Edited to add: the "Copy/Print Job Status" in the Status Monitor on the printer itself, is empty. 

Edited again to add: I can successfully print that 2 page PDF from my iPhone.


Hi Hector -- thanks for replying!

The issue sorted itself out when my laptop updated to OS 13.6.1 (22G313). Everything works now.

I have no idea what the problem was.

View solution in original post


Product Expert
Product Expert

Hello Ladysun1969,

The issue that you are describing, looks like a problem with the printing system or security software blocking the printer connection. If jobs are stuck in queue, you can try resetting the printing system again to clear the connections for the printer and the print queue. Click on the apple in the upper left hand corner of the screen and then click on system settings. Once in system settings click on Printers and Scanners. You can right click on a black spot in the printer list and select the option to reset the printing system.

Once the printing system has been reset, you can turn off any firewall or security software running on the Mac and then try adding the printer back to list using the add option at the bottom of the printer list. After the new connection has been added, you can try a print with the security software off to see if the issue has been resolved.

If you continue to have issues, it could be caused by a drop in network communication. You can try unplugging the router from the power for 5 seconds and then trying another print to see if it responds. If you continue to have issues, I would suggest contacting support over the phone at 1-800-652-2666, our agents would be happy to assist.

Hi Hector -- thanks for replying!

The issue sorted itself out when my laptop updated to OS 13.6.1 (22G313). Everything works now.

I have no idea what the problem was.

Enter for a chance to win