Showing results for 
Show  only  | Search instead for 
Did you mean: 

Scan-to-Email problems on IR-ADV C5255


Hi there,


We've had this machine for years and it's worked just fine. We recently moved offices and have a new ISP. Since the move, our scan-to-email function is not working.


Our dealer servicer has been out and upgraded the firmware, reset all the various options and settings, and it appears that everything should be working, but it isn't.


The one setting we're unclear about is in Preferences > Network Settings > DNS Host/Domain Name Settings.


In the manual linked below on page 19, step 16. I do not know:

  1. What the correct host name and domain name entries are, and
  2. If these have any bearing on causing a consistent SMTP authentication error.



We are trying to connect it to a Gmail account and have all the settings correct for this to work – as it had been prior to our office move – but it's just not working.


I realize that Canon staff do not answer support questions here. However, our service dealer is unable to do any more for us. They do not know what the Host Name and Domain Name values should be. They do not know if this is causing the SMTP authentication failure. They directed me to the Canon website, here, for help.


Thanks in advance to anyone able to offer any guidance for us.



Quick update here for people facing the same problems.


We have fixed the issue, finally. The DNS Host and Domain name settings seem to play no role in the SMTP issue. Once our servicer updated the firmware and made sure all the SMTP settings were correct, we realized that we had made one small change in a setting in the Gmail account that is key to this working.


While he was working on the machine, he asked us to turn OFF the Gmail setting labelled "Allow less secure apps". We had not turned that back on. After turning it back on, everything is working again.


So, for others facing the frustration of getting the printer to email scans through a Gmail account, double check all your SMTP settings, upgrade the firmware to the most current version, which seems to have better support for the use of Gmail, and turn on this somewhat obscure setting in your Gmail account:

Hello Davemreed!


Welcome to the Canon Forums!


We're happy to hear you're up and running again. If you have anymore issue please let us know. 


I am trying to to set up the scan to email function on the C7260 Image Runner. we put in the right SMTP for gmail and the correct user name and password. but it is not working.


When we try to scan it says sending for a second and then right away says resending... and then eventually fails.

we are not receiving any error codes.


the scanning to our server is working, just emails do not work


If anyone has any information or tips to try out we would greatly appreciate it!! 

thank you

Hi, csitorsky!

Thanks for posting! While our forum community members are welcome to chime in, Canon does not provide direct support for imageRUNNER series products. Instead, your dealer will be able to help you! If you don't have a dealer and you're in the United States, please call us at 1-800-OK-CANON (1-800-652-2666) and we will be happy to provide you with the names of dealers in your area.

If you're outside the USA, visit and choose your country or region from the map for local support.

We hope this helps!

Hello, I'm having the same problem. I just bought a Color Image Class MF642cdw printer/scanner. I went to Remote UI, Settings/Registration, TX Settings, Email/Fax Settings and entered my gmail account as the email address to be used for the printer. I already did what the other person recommended, and enabled "less secure apps" on my gmail settings. 


But when I go through the process of scanning the document, and once I hit send scan, I get a TX Report saying "Error" but nothing else shows.  I'm really hoping someone can help troubleshoot what might be going wrong. Do I need to contact my internet provider?

Did you check the gmail seeing I described above? This was the missing step for us.

You should also double check the port settings on your printer/scanner. I believe gmail requires 465, but do a search to double check me I that.

It is because Google blocks sign-in attempts from apps which do not use modern security standards (mentioned on their support page). You can however, turn on/off this safety feature by going to the link below:


Go to this link and select Turn On


Moreover google block an ip when you try to send a email since a unusual location, so, you can unblock in the next link


and clicked in .


click here to view the gallery