Showing results for 
Show  only  | Search instead for 
Did you mean: 

My Canon Imageclass D530 Printer isn't responding when I hit print command


I use a USB cable to connect my printer to the computer. I can't make anything print out of the printer. I tried unplugging and plugging power cable back in. I tried redownloading the drivers and it still doesn't work. If anyone can please give me advice on this, please let me know. 



Hi jyh10001!


Thank you for reaching out to Canon USA, we're happy to help!


If you've installed the most up-to-date software and drivers for your computer's operating system from the Canon USA website (HERE), and you're still having problems, we'd recommend reaching out to our US-based technical support team for troubleshooting. They're avaible by phone at 1-800-OK-CANON (800-652-2666) Monday-Friday 8:00 am to 8:00 pm ET, excluding holidays, or anytime by email at


We hope this helps point you in the right direction!

Hi I understand. I have already talked to two techs from Canon and they are the ones who advised me about redownloading drivers and repowering printer, etc. I spent almost an hour with both Canon techs on the phone and it still didn't work. Can someoen please help me out here and give me some advice on how to fix this printer issue?


Hi jyh10001 


In order for us to better assist you, we will need some additional information.  Do you mind answering a few questions so we can get a better picture of your situation?

1.  What operating system are you running?

2.  Can a copy be made?

3.  Did you install using the disk or download the software from Canons website?


I look forward to further assisting you and receiving the requested information.


Please note, Canon's Forum is not intended for immediate help, but a place to allow for the Community to give you assistance and feedback. If this is an urgent support need, please use the link below to reach our friendly Technical Support Team:


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


Evidently the ImageClass D530 is not compatible with Windows 11.   Joy oh joy... we not only have to replace our computers / motherboards... but our laser printer too because Canon isn't supporting this printer any more.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th