Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎01-11-2019

MF8380CDW Printer not found by driver installer

[ Edited ]

I'm trying get the MF8380ZCDW office printer working on this Windows 10 Dell laptop.  Basically, I download the driver from here:


I run the driver .EXE installer, and select "Network Connection (for Network Models)" and click "Next".  The installer then searches for the printer on the network, but does not find it and gives a message "Device is not found".


Things I have tried:

1.  Set the IP address manually on the printer to  Set the IP address manually on the laptop to  Run an Ethernet cable directly from the printer to the laptop.  Confirm the laptop can ping IP address

2.  I've clicked "Search by IP Address", and manually typed in  But the same error comes up "Device is not found".

3.  I've clicked "Search Options" and set the search time to "Long".

4.  I've disabled the Windows firewall on the computer.

5.  I've removed all Canon software/drivers from this laptop, rebooted, and trying it all again.


I know the printer works, because I have another Windows 10 laptop that discovers the printer just fine with the same driver installer executable.  The problem is there is absolutely no troubleshooting information beyond "Confirm network connection and device is on".  Well obviously I've done all that, and it just won't find the printer.


What exactly is the driver installer doing when it is "searching" for the printer but can't find it?  I can ping the IP address from that same computer, so I know it's there....


powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement