Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF743cdw scanner error- 255,0,0


i have a MF743cdw and am getting a scanner error- 255,0,0 when using the MF scan utility.

it's a relatively new computer Dell 6 months old so everything is latest and greatest

was working in the past just fine.

am connected wirelessly to the printer and can print to it just can't scan from it.

printer is connected via cable to a laptop and that all works fine


Product Expert
Product Expert

Hello EP_C4,


That error can come up if there is a weak network connection, there is something blocking the scanner connection, or the computer needs an update patch for the scanner driver.


Scanning does need a better connection than printing. I would suggest starting by unplugging the router for 5 seconds and then plugging it back in. When the network is back up, you can try another scan to see if it works. If it is still not scanning, you can try disabling any firewall software and then try another scan.


If the scanner is still not working, I would need some additional information to assist further. If you could reply to this email with the version of the Mac or Windows operating system you have on your computer, we can continue to help. For a more immediate resolution to your issue, feel free to contact support at 1-800-652-2666. Our agents would be happy to help.

I have same problem. July 2021 went from hardwired network now wireless. Scanning has crapped the bed. Printer says I need to "Connect to Computer" and the UI scan utility FAILS with the 255,0,0 error. The UI utility is useless. Update patch for the Scanner Driver??? "Weak network connection" >>> please elaborate on this?? The device prints fine and wifi is hihg throughput and strong signal....... Please help there are multiple unanswered threads on this EXACT topic with the MFC743cdw

Hello Thomasjohnlynch,


The error would usually point to a weak connection, but if you have switched the network connection from wired to wireless, you would need to reinstall the drivers for the MF743Cdw. The MAC address for the wireless scanner connection is different than the ethernet connection. You can download and install the recommended driver for the MF743 at the top of the list found at the link HERE. It will find the new connection for the scanner and add it to the scanner software.

thanks did all that nonsense.   I got a Netgear wall ac to GIGE bridge and hard wired a switch to my office and the printer and its working fine.....  crappy wireless implementation, the paper handling User Interface is also the most bizarre and compliecated I have ever used since WordPerfect backin the 1990s.  Useing Word and trying to print a simple envelope.  Watching videos and setting papertype and playing with the Canon user interface.   OMG ridiculous.


Never solved this problem, just went around it or went back, cost me a hundred plus.    Had to buy another $350 in cartridges 80% of the printers cost????  Yikes.