Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF642CDW Tried to print, but only gives a long beep and nothing prints


As the title says, I tried to print a photo on my printer from my PC but all it does is give a long beep (About 2~3 long) and nothing prints. There's no paper coming out too.

I checked the print log and it says error #822, which is "format of the file is not supported". But I tried jpg, jpeg, png, and nothing works.

Thing is, I tried using a USB, and this time a piece of paper comes out with the word "ERROR" on the top left corner. (Definitely not a feeding issue)

I still get the same error number on the print log though.

I've also tried the "Print test page" from the properties window on my PC and it still does the same beep and nothing coming out.

Any way to fix this?


Product Expert
Product Expert

Hello Giragiragun,

We would be happy to assist with the issue. To provide some feedback or some troubleshooting steps, we would need some additional information. If you could reply to this message with the information below, we can provide some assistance. For a more immediate resolution, you can contact support over the phone at 1-800-385-2155.

  1. What version of the Mac or Windows operating system are you using on your computer and what program are you printing from?
  2. Are you able to print documents from the computer or images from other programs?

1. I'm using windows 10 and tried to print using "windows print picture", "chrome", and "windows paint"

2. Nothing works. Pictures, PDF documents, they all have the same issue.


I've tried redownloading the driver as well but nothing changed.