Showing results for 
Search instead for 
Did you mean: 

MCF735 cannot be found


Trying to install printer on new laptop, running driver utility set up results in printer never being found.  Can ping the printer just fine, could back end install the printer from the computer's printer set up.  Thus prints just fine.

But cannot scan because the scanning drivers are not installed.  Scan utility set up ran just fine, but when you select to open it, gives no scanning drivers error.

I have tried plugging in the specific IP address to find the printer, no dice.  TUrned off windows firewall, no dice, 

It should not take hours to get a printer talking to a computer, it's already talking to, just to get it to scan.

I am out of ideas, behind pitching the thing out the window.



Hi, deerhart!

So that the Community can help you better, we need to know exactly which operating system is running on your computer (i.e. Windows or Mac OS, and which version thereof). That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

should be windows 11

As I said I can print just fine, but when I actually try to use the driver installation tool, it cannot find the printer.  I can ping the IP address the printer gives me from the computer prefectly fine. I've killed the firewall, the computer can see the printer if I go to printers and look for a printer on the network (which is how I got it to print).

I've made the computer findable and sharable on the network.

I just can't scan to this computer and when I try to run the scanner utility installed on the computer it tells me the scanner driver was not installed.


If the printer has a valid IP address and the setup is unable to find the printer during the install it could be an issue with network communication but usually it will mean there is something blocking the setup from detecting the printer properly. You can try unplugging the router from the power for 5 seconds and then plugging it back in. Once the network is back up, you can try the driver install again to see if it can detect the printer. If it still does not find the printer during the driver install, you can turn off the Windows firewall as well as any other security software that is running on the computer. If the printer is still not detected during the setup, I would suggest contacting our support team at 1-800-652-2666. Our agents would be happy to assist with checking what is preventing the setup from finding the printer.

06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM