cancel
Showing results for 
Search instead for 
Did you mean: 

ImageClass D1620 the scanner feeder doesn't work

ShW
Apprentice

Dear All,

I have ImageClass D1620 bought half year ago, recently trying to scan by feeder. Everytime, when I power up the computer, I have to re-install the driver if using the feeder feature, or it'll show the error message as below.  The greyglass scan feature is fine.  However, with a bunch of paper to scan, the greyglass one-by -one scan is impossible task. Does any one know about this issue.  

"Cannot  communicate with the scanner.  The cable may be disconnected, or the scanner may be turned off. Check the scanner status and try again. The scanner driver will be terminated. 

Code: 155,0,0 "

 

After the error message, re-install the driver will fix the problem, but if turn off the computer, next morning, power up, the same error message pops up.  

Does any one can help?  I tried to call support, but their phone system is like a labyrinth. 

 

Thanks

Jolin

4 REPLIES 4

Audrey
Product Expert
Product Expert

Hi Jolin,

 

Thank you for your inquiry, and welcome to the Canon Forums. We appreciate your participation, however, for the community to best assist you can you provide us with the following information:

 
1. Operating System of the computer?
2. How is your printer connected?
3 .What files did you downland and install?

4. Are you scanning with MF Scan Utility?

 

If this is a time-sensitive matter, our US-based technical support team is standing by at 1-800-828-4040 weekdays between 10 AM and 6:30 PM ET.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hi Thank you for your support! To answer your question:
1. Windows 10 Pro 64 bit
2. by USB cable (the third jack on the back panel of the printer)
3. Install from the CD driver come with the printer
4. yes , MS scan utility
The greyglass one-by-one is working, but not the feeder, unless delete the driver from the computer and re-install the CD driver every time once turning off the computer and powering up.

The printer serial number 2SN[xxxxx] , bought from Amazon on August 2020.

 

[Serial number edited to protect privacy.]

Hector
Product Expert
Product Expert

Hello ShW.

 

If you are having to reinstall after restarting. I would suggest unsintalling the current driver and MF utility. Once the utility and the drivers have been uninstalled. You can download the latest version of the drivers and software for WIndows 10 using the link HERE.

 

You will want to download the [Windows 64bit] D1650/D1620 MFDrivers that is under recommend Drivers. For steps on how to uninstall the the drivers and the MFUtility, you can use the link provided HERE.

 

Did this resolve your issue? If so, please select accept as solution so others can find the answer.

Dear Expert, I followed your link to uninstall and reinstall. It works when the computer is started the next day, but it does not work on the third day. This is the same problem as before.  

Should it be sent to you for repair?

Announcements
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM