Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MF4350D printer gives default error...newly installed on Windows 10 home


My HP laptop was hacked and I had to have the disk wiped and reinstall all applications. The Canon MF4350D will not install. I have tried to update the drivers but it still does not work. It is installed through port 2, not networked. I know this printer is old, but it is a workhorse and it does everything I need. I have the original disks but this laptop does not have a disk drive.

I am not computer literate but have installed many different programs and devices without a problem.

I hope someone can help me out. 



Thanks for letting us know what Canon product you've got. The imageCLASS MF4350d is an older model which we have retired. While that means that Canon USA no longer offers direct support for it, your friends here in the Canon Community are welcome to offer suggestions!

You can also speak with a Canon Upgrade Program specialist to help you score a modern replacement that would meet your current needs at a discount. You can reach them weekdays and Saturdays at 1-866-443-8002.

Hope this helps!

Thanks...the scanner works so I'm sure it is a print driver application that I need. Hopefully the community will have a solution because it worked a week ago.