Showing results for 
Show  only  | Search instead for 
Did you mean: 

2100009 Error when trying to scan on a new Mf733Cdw




I have an iMac running OS X Mojave, and for some reason, this computer alone does not recognize the scanner functionality on the MF733Cdw.  Instead, I get an Error 2100009.  


I can print successfully to the MF733cdw from this same computer wirelessly no problem.  It's just the scanning that doesn't work. I am using Google WiFi for my network. I also have VueScan on my Mac, but no luck from there either of course.


I have tried deleting the scanner from the OS X "Printer and Scanners" settings under System Preferences and reinstalling the drivers from scratch using the files on the Canon USA website for this MF733CDw, but I still get this Error 2100009 consistently when trying to scan from this iMac.


What troubles me is that even after reinstalling the scanner drivers manually on this OS X Mojave iMac,  I cannot see the Scanner icon in the list of scanners (in the OSX Printers and Scanners settings popup), yet the scanning software (both Canon and Apple's) is all there.


Any ideas on what I should be doing to resolve this?   Thanks very much for any help!


Canon 2100009 Error - Screen Shot 2019-10-06 at 8.27.56 AM.png





Assign / Give the scanner a staric IP address on your mesh system, then re-add to your MAC using this IP and see if this resolves the no scan behavior. 

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

I've had my printer/scanner a year and for the last month I've had nothing but problems.  I've tried calling the help line and am left on hold for over an hour.  I've reinstalled the drivers several times.  Finally got it to print again but it will not scan.  Not from the machine nor my computer.  I have no idea what a mesh system is.  In layman terms can someone please help.  I need my scanner for my business.  Thank you

Hi tcoulter35.


In a mesh network, rather than having a heirarchy of devices (Modem > Switch > Bridge > Router > Hub) managing the network information, every device past the modem acts as a same-level signal repeater to get information back to the modem.  This creates a "mesh" of devices acting both independently and in coordination.


One problem that may affect this printer on a mesh network may occur if the mesh is set up such that each node on the mesh effectivley acts as its own router/access point, rather than acting as distributed pieces of a single, unified network.  Check the mesh network's settings to ensure it's set up use a single SSID ("Name") rather than incremental SSIDs ("Name.001" "Name.002" etc.).


A static IP address may be set on the printer itself, though it helps to also set the static IP address in your modem or router's settings.  Refer to the router's documentation and support for information on setting up a static IP address for the printer.


If you need immediate assistance with this issue, please contact us using the numbers and information at


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.