Showing results for 
Show  only  | Search instead for 
Did you mean: 

SELPHY CP1500 Persistent paper jam message, Paper size misreported


When I got my new Selphy CP1500 in August, it worked perfectly.  However, I am now trying to use it after a few months of inactivity, but I am having several issues.  First I had to delete the app and reconnect my smartphone to the printer in order for my phone to send photos to the Selphy CP1500 to print.  That worked, but now whenever it starts to print, before the printer even ingests the paper, it stops and the display says there is a paper jam and to turn the printer on and off.  I do, and the printer ingests the paper and then releases it onto the tray without printing anything.  I tried removing the tray several times and wiping out/blowing out any dust, and it keeps giving me the same paper jam error.  It has also started sometimes telling me that the wrong paper size is loaded.  The paper is the same one that I used without a problem when I first got it, and I verified that the tray says "P," which is the paper size the printer screen is asking me for.

Very frustrating!!  Please help.



Same exact issue. I haven’t used the printer since Christmas and now it is making clicking noises and not picking up paper. Error keeps coming up saying that the paper cassette is empty. 

Product Expert
Product Expert


Based on this type of issue, I recommend reaching out to Canon support. You will need to register your Canon gear HERE to access additional support options.

We look forward to hearing from you. 

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th