Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot set up Brand New Canon Selphy QX10 - iOS14


I've downloaded the Selphy Photo Layout app and followed the on-screen instructions but it just won't connect. Even though I've enabled all of the permissions, deleted and reinstalled the app, turned off "private address" mode in the wifi settings of the QX's own wifi network....nothing works. It still says "Connection has failed. Grand permission to use the local network". well, when i check the permissions, it's enabled (!!!). 


I even tried this on a separate iOS device and it gave the same error. 



Screen Shot 2021-01-22 at 7.09.46 AM.png

Screen Shot 2021-01-22 at 7.11.52 AM.png

It would appear that this is a PERVASIVE iOS14 problem. I was able to connect a friends' Android to it so I know it isn't the printer's problem, but it certainly is canon's problem with iOS14. I'm returning since I use an iPhone and there's no point in waiting weeks/months for a resolution. 

Hi, kbraly!

Thanks for posting on our forum! This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Haha thank you! Thought canon support would be on here 😅 oh well. I returned it as I could not get it, or a replacement, to work on iOS 14.3! Darn!