cancel
Showing results for 
Search instead for 
Did you mean: 

What's going on?

Is this forum going to be a casualty of the ongoing problems with Canon's new Web site? It's been several days, and the long pauses and spurious error messages haven't been addressed. The number of posts is way down. The Canon moderators have been silent on the subject; indeed, as I write this, there appears to be no moderator connected. I've foiund the forum useful and would hate to see its demise, but right now things don't look encouraging.

 

The new Canon Web site itself is a mess. It's much less user friendly than the old one (IMO), with simple items like user manuals being missing or absurdly hard to find. It appears to be just one more example of the change for the sake of change that characterizes so much of society these days.

Bob
Philadelphia, Pennsylvania USA
7 REPLIES 7

Danny
Moderator
Moderator

Hi, Bob!

Thanks for your concern.  We assure you that we're here and that the Canon Community Forum is still alive and well.  As you've noticed, we've rolled out a new web site in the past few days, and we're still fine-tuning it.  We've been told by our web developers that the forum will be smoothed out soon, including getting the header and footer sections taken care of.  Our developers' main priority is our core web site at http://usa.canon.com which we're rebuilding from the ground up.

Thanks for your patience during this time, and for all the help you continue to provide your fellow forum friends.

We hope this helps!

Thanks, Danny; I'll try to be patient.  Smiley Happy

Bob
Philadelphia, Pennsylvania USA

It really is unusable in it's current state.  

 

It takes many minutes each time I try to load a page.  If I open the error-console in my browser I can see a small handful (not very many really) of severe errors, but several of the errors are "request timed out" messages (which would explain why it takes several minutes to load a page.)

 

I also get a very large number of "warnings" -- mostly either "unexpected" or "invalid" CSS properties or tokens.

 

I had originally thought the problem was on my end, because who in their right mind would push new content into production without testing and, if those tests failed, would delay a roll-out until the errors were fixed.

 

So I tried different browsers... 

I tried wiping and resetting the browser (all cookies, all history, etc.)

I checked the DNS settings on my computer thinking perhaps it was just unable to resolve servers that might actually be valid (DNS attacks.)

I tried using entirely different computers.  I also tried from my phone and tablet.

I tried using different carriers in case the problem was with Comcast (my ISP).

 

Nothing I tried worked -- everything points to problems with the Canon site.  So I'm REALLY SHOCKED that someone would actually push this into production and then leave it that way for days on end (I think it's approaching a one week of being unusable.)  It is so unusable and it's been left in that unusable state for such a long time that it made me wonder if Canon isn't the victim of a malicious hack.

 

But then I noticed the rest of the Canon site is being revamped (I've already sent feedback.... the "new" site is terrible and has several aspects that make it less useful than the old site.)

 

For example... if someone asks "where can I find the manual for my camera", I used to be able to provide a link that would probably fit on just one row of text.  Now the link is hideously long, loaded with gibberish, and possibly not even useful to a different user (I'm trying to figure out if all of that gibberish is actually part of a link to a specific page, vs. extra gibberish which is really associated with my user session and nothing to do with the page I'm trying to link.)

 

Anyway... some of the most serious errors (pages components that are not found or time-out) can be fixed in a matter of minutes.  But the overall site re-design will probably take months to repair all the damage.  Canon needs to take a step back and evaluate success criteria.  They neglected to take into account why people come to the site, what they look for, how they would like to search, how they ask for help, and how we provide that help.  Now our ability to provide direct links is probably gone (at a minimum, that needs to be fixed.)

 

 

Tim Campbell
5D III, 5D IV, 60Da

Hi, Tim!

Thanks for the feedback.  We actually haven't noticed any performance issues with the forum at this time.  Despite the moderators (including myself) being Canon employees, we access Canon's web sites through a regular internet connection and we use normal, everyday web browsers.  Aside from the "We're sorry" error messages at the header and footer of the page--which appear to be a coding item that's on our developers' to-do list--we haven't noticed any other issues with pages taking too long to load or failing outright.  We'll keep an eye on it, though.

Are these page-loading issues something you've encountered only since the site redesign, or have you been having this problem longer than that?

We look forward to your feedback!

Hi Danny, I tried to respond with more info, but apparently the reply never went through (this is part of the time-out issues with the site.) If I use a browser that has an error console, the console will show a number of web server errors "500 Internal Error", 404 page not found errors, request timed-out errors, etc. I also get quite a large number of warning messages about bad CSS content on the page. Some browsers will show content even on a page that hasn't loaded. So while I can see part of the page using Firefox, I can also see that even as I'm writing this reply, the page is still trying to load ("connection to nw.cusa.canon.com..." appears at the bottom of the browser window.) The page load times seem to be taking about 2.5 minutes (that timing is rather consistent). Most users expect pages to load within just a few seconds and will give up within if things don't load within 10 seconds. You should (hopefully) be checking your website using all major browsers (Safari, Firefox, Chrome, and whatever Microsoft is calling their browser these days) and should also be testing popular client platforms (Mac, PC, iPhone, Android Phone, iPad, etc.) It's possible (likely) that you have geographic load balancing and multiple content caches (e.g. "Akamai" like services) and that the servers responding to me are not the same as the servers responding to you. I did try on two different Macs, three different web browsers, reset the browsers (reset cache, cookies, history, etc. etc.), also tested using a box using Ubuntu Linux and a Firefox browser (I don't have a Windows PC available to test), and an iPad. I also tried on my home (Comcast ISP) network and tried while away from my home on the Verizon network. Browser, device, device type, and network seem to make no difference -- indicating that this is almost certainly a server-side issue.
Tim Campbell
5D III, 5D IV, 60Da

I just loaded the website this morning.  The performance is MUCH faster.  The 'request timed-out' errors seem to be gone now.

 

Thank you!

 

Tim Campbell
5D III, 5D IV, 60Da

See?  We're looking out for our forum family, and we're just as glad to see the forum back on its game as you are!

 

Thanks for your continued support!

Announcements