Showing results for 
Show  only  | Search instead for 
Did you mean: 

Print Studio Pro mac osx 10.15 Catalina error


macosx 10.15

Canon Pro-1000 printer

Photoshop 2019 CC


I upgraded to mac osx 10.15 catalina, and now whenever I open the Print Studio Pro plugin in Photoshop CC 2019 it crashes instantly and says "And error has occured... Print Studio Pro will now close" and my only options is "ok".


I tried reinstalling with a fresh copy of the plugin off the canon website and it still won't load. 


I wish I could use the standard photoshop print dialog but even selecting my MOAB paper profile the print still turns washed out and ugly.


Has anyone solved this?


Paul, go to the Print Setting dialogue box Printer Setup when you first attempt to print. In the dropdown is "Color Matching". You'll see ColorSync greyed out. This indicates that PS is managing color not the printer. As a way of testing this select Printer manages Color and revisit the Print Settings option. You'll see you have an option to change what was previously greyed out. 

Hopefully this helps. Make sure you screen is calibrated orr you may get different results from the prints. Screenshot 2019-12-10 at 21.15.52.pngScreenshot 2019-12-10 at 21.15.52.png


I am having the same issue.  I called Canon last November and was told the software should be updated for Catalina by December.  I have checked each week, but so far nothing is available.  I called Canon support today and was told this issue is their number 1 complaint, but was told they do not know when or even if an update will be made to run on Catalina.  But I was told Canon did update the software to run on Windows 10, which is a 64 bit OS.  I guess this is just another example of Canon's lack of support for Apple product users.  I know this will be last Canon printer.


I came to this topic back in December when I couldn't use my Pixma Pro-100 due to the Studio Pro error occurring in Mac Catalina. I thought Canon said an updated driver would be available by the end of the year (or sooner). Now it's mid-January and still nothing-- and I am not able to use my printer. I cannot express how aggravating this is with all the prints I need to get done plus paper and extra ink up the wazoo.  If Canon does not fix this soon, I'm selling off this big paperweight and going to Epson. Screw this nonsense. 


I could not update our Print Shop Prp either after it stopped working when I upgraded to Catalina. I called Apple and re went back to Majva (sp?) and it works again. Print Shop Pro needs to come out with a new software program in order for us to use it with Catalina, I was told from someone at Print Shop. I also have 6 other programs that didn't work. I purchased office, excel, and powerpoint, but my brother printer will not work including a couple other pograms if I upgrade. So, I am NOT upgrading to Catalina any time soon! These program should be updated regularly!!  I hope they get this taken care of quickly! I'm very frustrated too! 

Hi all, this is a repost of Silvasolve , which fixed the problem for me:




The reasons for this are apparently the annoying new security provisions introduced with Catalina.


I was able to sove the problem by manually adding Print Studio Pro (and the other Canon Utilities) to have full disk access.


Go to Apple Menu -> System Preferences -> Security & Privacy, click on the Privacy Tab and scroll down to Full Disk Access and select it.


Click on the lock Button and enter your admin credentials, then click on the "+" button and locate Print Studio Pro (should be in the Canon Utilities within the Applications folder).


See attached screen shot.


Now Print Studio Pro should open up as usual.




Hope this helps,


Screen Shot 2019-11-01 at 04.52.21.jpg


Hey Slingerland85,


Thanks for posting the fix.  Print Studio Pro now works on my iMac with Catalina 10.15 installed.  One thing I would like to point out is if someone already has installed Catalina and goes to Canon's website to download the software, ttheir site will automatically detect that Catalina has been installed and you will not be able to see the Print studio Pro downlaod link.  Just click on the dropdown box and select MAC OS Mojave 10.14 and the link will appear.  I still do not know why Canon has dragged their feet on this for so long.

Didn't work for me.  Still get the "Destination Folder for this Operation is Missing" /Library/Caches/Canon/PrintstudioPro/PrintStudioPro_LR-Tem