Showing results for 
Show  only  | Search instead for 
Did you mean: 

New site not working?


I can NEVER get the USA shop link to open on my iPhone in Safari. I end up having to go through social media and having the link directed into safari. Now today I try to do it that way and the store site has been updated and looks totally different. When I log in it says my account isn’t associated with that store but after I click around I can get into my profile but when I go to find my orders it seems to be logged back out and says to use another account.

anyone else having this problem? I preordered a lens on here and adorama to see which was the fastest and got a charge already even tho the date on the item says it won’t be in stock until the 23rd so I didn’t think about checking either store 5 days early. Now of course I need to cancel my order with canon so I don’t get the lens from both stores but I can’t use the store site to do anything useful. 



Hi!  We just redesigned our web sites from the ground up.  To follow up on an order, you can visit or you can call our sales support team at 1-800-385-2155.  They're open weekdays and Saturdays.

Hope this helps!

It shows me the menus to get to my orders but once I try to go anywhere it goes back to the log in page and says “Your account is not associated with this store.
Please try again with another account.”

I have tried 3 computers and my phone and get the same thing. But I know it’s all correct because it shows me as logged in and my account info but revert back to the login with that error message

Thanks for trying.  We recommend going with the alternative we mentioned in our last post which is to give our sales team a call at 1-800-385-2155.  They're open weekdays and Saturdays from 9 AM to 9 PM ET (6 AM to 6 PM PT).  We look forward to your call!

I still can't log into my account. The problem still exists and still posts an error message stating my account is not associated with this store, and to try a different account. I contacted Canon this same day and did everything they said to try to fix it. Nothing worked which I knew because I had already tried everything. They couldn't get the error themselves, but its definitely not anything I'm doing wrong on my end. They said they were going to put in a support ticket to see if someone higher up could help, but its now been a week and I haven't heard anything back. Its turning into the infamous Vystar app scenario except I can't get an update or find out if they're still trying to figure it out. Hopefully they extend everyone's warranty date(if they expire during this time). I ended up just having them cancel all of my orders for the indefinite future so I dont have any problems and so the warranty(90 days to add it) doesn't expire since there's unfortunately 0 word on a timeline for a fix. Maybe we can get an email sent out notifying people there's an issue with the new site and another when it is fixed so we don't have to try every day just hoping its been fixed.

Your warranty is not contingent upon registration. Your warranty starts on the date you purchase the product and is valid with proof of purchase. Your My Canon Account is there whenever you need some help, like re-downloading drivers or how-to videos, or if you were to need to contact support. 

exactly, so hopefully its fixed soon. how can one upload proof of purchase if you can't get past the log in. I just removed pre-orders and such so I don't have any surprises. Will re-order once the problem is fixed. I;m in no rush, but didn't want to put myself into one.

that number requires you to check your order status on the site. Which doesn't work for me because I am having the same issue as this thread and had to place my order anonymously.



Its a little kludgy, but I did get it to work after disabling my pop up blocker.  I added an EOS RP to my cart and took it up to the point of purchase. Anyway, its working fine, just not smoothly.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I just tried that and it’s still kicking me out unfortunately.


click here to view the gallery