cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Scanner LiDE 210, error 5,202,54

predshaw
Apprentice

My scanner, which has worked perfectly fine up until now, now comes up with the error Code 5,202,54 'Internal error occurred, scanner driver will now close'. I am running a windows 8 system. I have uninstalled and reinstalled the driver/MP Navigator a number of times but the error continues to appear. Does anyone have any tips? 

10 REPLIES 10

Monial
Apprentice
Many similar issue reported on various forums/threads. Looks like everybody running W8 or W10 is facing the same issue which Canon doesn't care about.
Recommendation is to bring the device back to the dealer in case you missed those forums before you buy.
I personally replaced this Canon crap with a HP ScanJet 300 which took me 10mn installtion time and works like a charm since then

Scott1
Apprentice

What worked for me - and I am AMAZED this worked - is replacing the cable which connects the printer to my laptop with a NEW, SHORTER CABLE (3 FOOT). Someone recommended this on another site and I thought, you've got to be kidding. I'd previously tried every other end-around, e.g. downloading new drivers, turning the computer off and on, etc., and some of these methods succeeded at first, but then, out of nowhere the dreaded "hang" would return. My old, original cable was 5 or 6 foot, and a user noted that power can diminish over a longer connection. Also, my older cable had one of those cylindrical "bulges" in the middle of it (sorry, I don't know the term for this) which would cause the cable to hang in a U-shape unless the entire cable were laid on a flat surface (not possible in my setup); my new, shorter cable has this "bulge" also, but I wonder if the U-shape bend might affect power transmission on a longer wire. Please note, just to drive me crazy, the first time I tried a 3 foot cable there was NO improvement. I then tried another 3 foot cable - one I had lying around - and it DOES work. I can't explain this, unless there are subltle difference between manufacturers? The cable which did not work came from "Amazon Basics," though it works fine when connecting other peripherals, like my external drive. The required cable type is "USB Male to Mini B." I don't know if specifiying "USB 2" or "USB 3" makes a difference; the cable that does not work is labeled "USB 2," the cable that does work is not labeled. I'm running Windows 10 on an Asus laptop made in 2013. I hope this helps! 

The bulge in the USB cable is a ferrite tube, moulded on with plastic. It is there to suppress Radio Frequency Interference and

allows equipment to pass FCC 15 and EN55022 EMC regulations.  I tried your short cable fix, going to a 2' cable and then a 1' cable from my USB hard drive.  Neither worked. What did work was changing to a different USB port on my laptop. This scanner has worked fine for 6 years on this laptop under Win 7 and Win 10 - until now. Why the problem now?  Who knows?

JackNathan
Apprentice

Perhaps you could try plugging the USB connector directly into a different port on the computer - seems to have worked for me.

JackNathan - worked for me too. Thanks for the tip. Maybe it is a USB3.0 port vs 2.0 thing? I am not sure.

ElGat
Apprentice

I guess they are all dying in 2018... mine was working fine, I was scanning a few documents and the message appeared when I was between scans, very strange. None of the suggestions have worked, (shorter/different cable, different port, different computer) so I guess it's gone to the great recycling facility in the sky... disappointed as it was a great little scanner!

If someone has another suggestion, please let me know, Thanks!!

The problem disappeared when I quit using USB 3.5 to connect my Canon scan Lide 110. Alright with 3.0

I have the same issue. I have used my 210 with the same laptop for many months and at least once a month and then today it stop with the 5,202,54 error..

I have tried the advice of others to use other USB ports and have tried all the ones that I have but that has made no difference either and I have also re-installed the latest drivers from the Canon site and that has not helped either.

Could someone from Canon please chip in with some help.

I am pleased to find that I found a fix on another site that works for me. It's not ideal as you have to go through the steps each time you want to scan but it works. 

The fix can be found here: https://printproperly.home.blog/2019/06/18/how-to-fix-canon-scanner-error-520254/

Avatar
click here to view the press release
Announcements