Showing results for 
Show  only  | Search instead for 
Did you mean: 

CanoScan 9000F Mark II - Internal Error


I hope I am in the right place to ask as I'm new to the CanonCommunity.


Anyway, I recently purchased a CanoScan 9000F Mark II here in the UK and ran through the basic set up inaccordance with the CD Rom disk, which duly installed My Image Garden on my PC and I was then instructed to power the unit up. This I did and all seemed to be well so far.  However, as a test of the unit I inserted the 'slide' film guide mount and added four slides and then performed a 'Auto Scan', but almost straight away I got a message on my PC that "an internal error has occured - exiting from this software" and was duly dumped!!   I made a few more attempts with same result and have checked all connecteions and My Image Garden seems to operating OK on my PC.


I am now stuck as to what to do and hoped that perhaps the more knowlegable amonst the Forum members may be able to assist??


Regards Longframbri


Product Expert
Product Expert

Hi Longframbri,


Please try the following to see if we can resolve your issue:


1.  Turn the scanner off.

2.  Disconnect the USB and power cables from the scanner.

3.  Toggle the lock switch back and forth about a dozen times alternating.

4.  Leave the switch in the unlocked position.

5.  Reconnect the USB and power cables.

6.  Turn the scanner on.


Once this has been done, try scanning to test the unit. If you still getting an error, you will need to contact Canon UK for further troubleshooting. Please click HERE for their support page.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.



Thanks for that and sorry for the delay in responding but have been away. Will check that all out tomorrow and get back to you. Thanks again.

Hi Arthur,  It looks as though the problem is with the installation of My Image Garden on my PC and maybe the steam driven Windows 7 that I am still running (I know its old hat but I am comfortable with it!!).  The reason I say all this is based on the fact that I ran the installation programme for the CanoScan 9000F Mk II on my more up to date ACER notebook computer, which is running Windows 10, and this proved successful with a test scan offering up 4 slides all OK.


I firstly did the steps for the scanner as you suggested and a repeated attempt of scanning 4 slides on the scanner using the desktop PC revealed the same negative result, but this time I paid more attention.  The error message that flashed up is actually a Canon My Image Garden message, which reads "An internal error has occurred. Exiting this software", which I assume means the My Image Garden software.   As mentioned above, using the Acer notebook rather than the Dell desktop PC proved successful with the scanner behaving perfectly. 


Do you think that the PC running with Windows 7 Home Premium is the issue with the software internal error isssue??  I could of course update the windows version on my Dell PC as I have that option or maybe I just use the ACER Notebook for scannin my slides etc.  Incedentally, the reason that I purchased the CanonScan 9000F MkII was to facilitate the scanning of a large number of slides that I have covering the time we lived in Japan from 1983-86, togweether with other slides and photographic negatives.


Any more thoughts or advice in this regard??

Hi Longframbri,


At this point, I recommend contacting the branch of Canon for your region to narrow down this issue. You may find the correct website using the map on the Canon Global website:


We look forward to hearing from you.

click here to view the press release