Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot Schedule/Pay for Maintenance via Canon Support Website


Last weekend, I posted about being unable to register a CPS account on Canon because each time my email address was automatically flagged as invalid. Well, that problem was fixed, I created a CPS account, registered two of my Canon products (R6 and RF 70-200/2.8L), and now I am trying to schedule and pay for maintenance. I have called Canon to leave feedback. I have left feedback for the IT team. But maybe you all can help me if I am doing something wrong? I get through the entire process, provide my credit card information, and click Submit and then get an error message (below). BUT my credit card is charged $1.00! Nothing else happens. I got the error message, my CC is charged $1.00, and no confirmation email is received by me.

I am beginning to think that the Canon website is maintained by a bunch of middle school kids somewhere. This supposed first-rate company has been knocked down to third-rate experience in my eyes due to my struggles with the website since last Saturday. I mean we are talking simple, elementary things this site should be capable of doing. The very basics!

Can anyone help? Am I alone here? Can someone contact me? I have logged out, logged back in, cleared cookies, tried different browsers (Chrome, Edge, Firefox), tried on different days. Nothing helps.




That phone number is for our Service Information Group. They can look into this with you to see what is causing the transaction to fail. For privacy, you will need to speak with someone by phone.


 Thanks, Stephen.

Middle school kids are a lot smarter that we think. I knew of one who would solve computer hiccups for the high school teachers.

Canon EOS T7; EF-S 18-55mm IS; EF 28-135mm IS; EF 75-300mm; Sigma 150-600mm DG


One aspect of online credit card information can be how the web interface handles the input.  I have experienced (not with the Canon site) times when I would cut and paste a credit card number into the page and it is not recognized as "valid."  Inputing the same information using keystrokes works.  I have never had any issues with Canon's web pages but when I have had questions of problems the CPS personnel have always given me the right solutions.  Hope this helps.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th