cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Webcam Utility not working with MAC

Ablongro
Contributor

I have a MacBook Pro and I have no been able to use my EOS Webcam Utility for a while now since this last update.
I have contacted Canon and just get told “we are working on it” in the meantime I still have to pay for my subscription the entire time.

i attempted to reset my computer with apples fix but that did not work and frankly im not a computer wiz. They want you to reboot the system and add in some code. 

I don’t really think that is fair to charge for a service that I can’t even use because Canon software can’t keep up with Mac updates. 

 

Does anyone else have this issue? Or have a work around for having to use the canon software? Is there another more reliable software that can be used with Mac and zoom? 

7 REPLIES 7

Kristoff
Rising Star

Thanks for joining the conversation, Ablongro!

So that the Community can help you better, we need to know exactly which operating system is running on your computer (i.e. which version of MacOS). That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

I have a MacBook Pro with intel chip. 
operating system is the latest Mac Sonoma. 

I and other fellow Canon users do not understand how this is constantly an issue with every update when Apple works with third party applications to help keep their software up to date for these update releases. How is a large company like Canon so far behind everyone each time. It is so frustrating. Sony doesnt have this issue. 

randomname88
Contributor

Hey Ablongro

I have the same problem since this weeks Mac update (14.2). Canon had access to the developer release of macOS Sonoma 14.2 months ago, like all Apple developers - it's an absolute disgrace this happens, and shows that software is not a priority to them.

The EOS Webcam utility is an absolute joke of an app, like something from the 90s. I could tolerate it if it worked, but right now my £1100 webcam is a brick, and this will be my first and last Canon purchase

 

The last update was rough and took about two months. This one seems to be taking even longer and it has caused me so many issues with my original work flow. 
I finally got it to work on my Mac but only using the wifi connection but then a background task on the web utility software takes up more than 50% of my CPU usage to the point that my fans run full-time. 

I unfortunately can not stop to learn a whole new platform. And at this point im half tempted to us Ai+Chatgpt to write my own coding software and make my own app. lol 

if you have not got to that point then here is the fix. 
Not ideal but this is what fixed it for me. 
I followed the following articles instructions BUT what it does not say is what I found deep in another forum. 
BEFORE you start your Mac in recovery you have to go to your settings, privacy and security, scroll down to File Vault and turn off file vault.
this will let you run the code in terminal on the reboot. 


https://support.apple.com/en-us/HT213969

But even after all that the only way I could get the webcam utility to work was not through a hard wired connection, only a wifi connection. 

randomname88
Contributor

Yeah I used the https://support.apple.com/en-us/HT213969 solution to make it work with Sonoma 14.1. This workaround was ridiculous but at least it worked. (it also suggests Canon didn't work on any Mac software for several months). 

Now it doesn't work at all as a webcam/streaming device (the EOS logo appears in Zoom, iMovie etc, but there is no feed and no icon appears on the camera screen.

Great hardware, terrible software.

harmerj7
Contributor

Same problem here with Sonoma 14.2

aleksiralda
Apprentice

I have the same issue running Sonoma 14.2 in Macbook Pro 14" 

Avatar
click here to view the gallery
Announcements