Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS webcam software failed to install on windows


I am getting a EWCSERVICE failed to start error and somone else had a smilar problem but posted the question under  a mac issue/post.  So I'm starting a new thread.

I am an administrator.  I think I've turned off virtually all security related filters from this brand new PC (out of the box) and have no idea how to solve this.




I also received this error as of a few days ago and have scoured the internet for direction. I've gone through policy and added everything as a user but to no avail, nothing. 

Product Expert
Product Expert

Hi jirey,

I'm sorry to hear you're seeing an error when you try to install the EOS Webcam Utility. Is the error showing immediately when you start the launcher, or is it showing further in the process? If it is happening further in the process what step is showing up on? Also what version of the Windows operating system are you installing the software on?

One general thing to double check is the version you are trying to install. If it is an older version it can cause issues on installation. The current version can be downloaded on the product pages for compatible cameras. I do not see a listing for which camera you are using the software, but it is the same version on all the product pages for compatible cameras.

The current can be downloaded on this product page HERE. Once you are on the web page click on the Software & Drivers button and the current version is EOS Webcam Utility Pro 2.0 (Windows).

I've tried downloading EOS Webcam Utility Pro 2.0 on both windows 10 and 11. The same error has popped up on both. 


I am having the exact problem.

I had OBS and EOS Webcam utility (ver1.22) under windows 10 on my laptop and it worked perfectly

then I had to replace the SSD.

I am trying to reinstall EOS Webcam utility (ver1.22) under windows 10 22H2

The installation does not complete and rapport the error:

“Service EWCService' (EWCService.EXE) failed to start. Verify That you have sufficient privileges to start system services.”

I tried installing three versions:
EOS Webcam utility (ver2.0.30) FAILED
EOS Webcam utility (ver1.22) FAILED
EOS Webcam utility (ver1.14) PASSED

Not sure if it is a Windows update conflict as I can install all three these version on my desktop under windows 10 22H1