Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS webcam beta won't install


Downloaded and tried the installer today.  When I run the installer, it says...


The installer was interrupted before EOS Webcam Utility Beta could be installed.  You need to restart the installer to try again.


It does NOT say WHY it was interrupted.  Restarting the installer produces exactly same results.


Computer is Win10/64 1903.  Everything else works.


Anyone know what might cause this?






No, since I have the same basic configuration and had no problem installing.


Did you try restarting the computer to see if you can clear a conflict?

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Product Expert
Product Expert

Hi there,


Yes, restarting the PC may help clear any conflicts as stated above and that would be a great place to start. It would also be best to verify that no other programs are running and checking any antivirus software you may have, including Windows Defender, to make sure they have not applied any restrictions to the installer program. I also suggest moving the downloaded installer file from your Downloads folder directly onto your desktop just in case the Downloads folder has any restrictions applied to it specifically.