Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam utility not installing


I always experience an error while installing the v1.0 of the webcam utility. After the "Preparing Installation" phase, it always give me the error message "EOS Webcam utility setup ended prematurely because of an error." Does someone also experience this? The beta version works just fine but this new one does not. Is there a fix to this? I tried restarting and turning off my antivirus and running it as adminstrator to no avail.





View solution in original post



I have the same or similar problem.


Is there some canon tool we can use somewhere to interrogate our computers and see what the problem might be?


I'm trying to install version 4 onto a  Win10 machine.  It seems to go okay and then reports that the installation was stopped because of some error.


then I find an icon for DPP on my desktop and a list of canon utilities in my list of apps  So I click on dpp and it starts to open and then gives up reporting that 'an error occured'  but that's all it tells me.


ddpw4.12.60-installer.exe is what I've tried ot use.


and the camera I want to use with it is a 400D.  And I have 350D, too.  I'd like to use that as well.


I know some versions of dpp won't work with those old cameras.


But the problem I'm talking about here now is before we get anywhere near the cameras.  I'm talking about a problem simply trying to install and run the software.


Any help?

same issue, i dont know a fix

I'm running Windows 10 20H2, installing EOS Webcam Utility 3.13.10.


Installation would start, prompt me for language, etc, then bring up UAC. I told it YES, and then a small box popped up and disappeared before I could read it, and that was the end - nothing was installed.


I realized that I was trying to run the install from a network drive and that I'd had problems with doing that before. I copied the software to my C: drive, tried it again, and it worked perfectly.


Hope this helps someone.

Product Expert
Product Expert

H there,


I'm not aware of a tool Canon makes to monitor the PC's processes and find what the hangup might be, I would guess anything preventing installation of the EOS Webcam Utility would likely block such software the same way. One thing I have found with Windows 10 is that it seems to be less flexible with how it treats setup files in the Downloads folder. You might have luck installing the program by moving the downloaded folder from the Downloads folder onto your desktop and running the installation from there. Also, you may not need to do this but since its one extra click I would recommend selecting "Run as Administrator" as you did before.

Screenshot (264).pngThanks for the reply.


Yep, but the point is such software would know when, at what point, it had been blocked and could report that - and then we'd know what was happening to our installs.  That's the whole point of such software.


I thought Canon had something. I must be mixing Canon up with someone else.. maybe HP,  they're pretty good at web based diagnostics I think.


Well that machine has just put in two hours updating its windows OS, all off its own bat,  I didn't ask it to do it.  It might work better after that.


Yep, I'll run as admin.


And I have windows Defender working and Avira has gotten in there somehow, too.  I'll root that out or at least disable it.


See how I go then.



In addition.  Strongly suggest you dump Avira.  After uninstalling, restart and run the software again. 


Ensure you are running Canon software downloaded and intended for the correct region where you live.


In case you are not in the US.


Q: What is the distribution for official version?

A: The beta version was only available in the USA. However the official version will be widely distributed in regions outside the USA. Please check the website of each country or region to see if it is distributed in your area, or contact your local service location.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hi, have you been able to solve this problem??,, i have the issue too

I kinda did and kinda didn't.


I mean I have it working now but I"ve got a new update of win10  - the 2004 thing.


MS did that to me and killed everything.  I had to do a new install. First they updated, everything went wrong, it wouldn't boot, and it wouldn't rollback so I had to do a new install and that, of course, is the current 2004.


So then I couldn't find an install package that would work so I hunted my old drives and found what I had used before:


canoneosutilityeuv3.10.0 -installer.exe a 124,689KB file and it installed fine.


That's mainly what I was after.  I haven't installed the dpp yet.  I'll get onto that shortly and let you know if you're interested.


Still trying to put things together on this new install.  I find win10 2004 disabled lan file/printer sharing by default, have to go to services and enable the appropriate function and then your lan works.  but the printer bit still doesn't work.


And I'm told they did that so's people would keep everything on the cloud instead of on their home lans.


That's all good. It's totally excellent.  Made up my mind for me finally after years of dithering.  I'm off to Linux.



yep, just installed dppw4.10.0 installer  and all went well, it seems to be working fine.


Im talking about EOS webcam utility ..installed yet ?
click here to view the gallery