Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility setup ended prematurely because of an error


Hello All,


Camera: EOS M50

Windows Version: Windows 10 Enterprise 2016 LTSB 10.0.14393 build 14393


I am currently trying to install the EOS Webcam Utility 1.0 Windows software and am getting the error "EOS Webcam Utility setup ended prematurely because of an error"


Looking in windows event viewer i have this error:

Driver install failed, result=0x80070422 for devnode 'ROOT\EOSWEBCAMSOURCE\0000'


I have tried everything from:

- Running the setup tool as admin

- Updated windows

- Try installing from different file locations ex. from desktop



Has anyone got this error and successfully solved it?





Product Expert
Product Expert

Hi Daniel123.


Thanks for checking in with us.


EOS Webcam Utility needs the following specs on the computer:

  • Intel Pentium 1.6GHz or faster
  • 2 GB or greater of RAM
  • Screen Resolution of 1,024x768 pixels or more
  • Screen colors of Medium (16-bit) or more

To check your computer specs, go to the search prompt by the START button and search for

SYSTEM INFORMATION. For screen settings, search for DISPLAY SETTINGS then navigate to


Hey Nick,


I have all of those specs and still have this problem:



OS Name Microsoft Windows 10 Enterprise 2016 LTSB
Version 10.0.14393 Build 14393
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer DTEN
System Model D7
System Type x64-based PC
System SKU To be filled by O.E.M.
Processor Intel(R) Core(TM) i5-7500 CPU @ 3.40GHz, 3400 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 1.07, 3/6/2019
SMBIOS Version 3.0
Embedded Controller Version 255.255
BaseBoard Manufacturer INTEL Corporation
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Mobile
Secure Boot State Off
PCR7 Configuration Elevation Required to View
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = "10.0.14393.3297"
Time Zone Pacific Daylight Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.92 GB
Available Physical Memory 3.99 GB
Total Virtual Memory 9.17 GB
Available Virtual Memory 4.63 GB
Page File Space 1.25 GB






Assume this is a laptop issued by an employer? (Nope, see now its a desktop)


Nick posted hardware requirements which I imagine your device in all probability meets.  They are not overly demanding.


This is a great document about the EOS WebCam by the way:


Can you confirm your hadware meets the minimum requirements?


You are running a LTS enterprise release of windows that is pretty old.  Its still under support however.  



Reference here (if interested)


The error you are receiving isn't specific.  It might be an issue with a service or the windows installer.  It could also be related to another driver or 3rd party software such as security or anti-virus.


Other things you might try:

Upgrading the OS to LTS 1809

Running chkdsk

Running SFC /scannow

Upgrading the video driver


Unfortunately the root cause goes beyond the scope of the forum and since the webcam utility is free, you will not get support from Canon beyond minumum system requirements.


Hopefully however, my post gives you a few places to start looking.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks Rick,


I should also note this is the computer on a DTEN D7 touch screen display. On the specs sheet they claim the os is : DTEN D7 OS, provisioned by D7 OS. 


This may be the issue and canon web cam utility doesnt support this dten yet. 




click here to view the gallery