Showing results for 
Show  only  | Search instead for 
Did you mean: 

my rebel t7 won’t focus


my camera won’t take pictures on the AF setting it will only take pictures on MF it wont focus can someone please help me it just started doing that



Hi there!

So that the community can better assist, we will need to know which lens you're having difficulty with, and if you've tried using any other lenses. 

If your question is urgent, please call support at 800-OK-CANON (800-652-2666), Monday through Saturday. 

If you're outside the USA, please click HERE for support options. 


The Shutter Button has two positions, half press and a full press.  The “half press” position has a click stop.  A harder press on the button will move pass the click stop and fully depress the button.

To use the autofocus system, you gently press the Shutter Button to the first click stop, which is called a “half press”.  This will engage the AF system.  You must maintain the half press until the camera achieves a focus lock.  

When the shooting mode dial on top of the camera is in the Green[A+] position, the camera will emit a soft beep when focus lock is achieved.  Now, fully press the shutter to take a photo.

Hope this helps.

"The right mouse button is your friend."

thank you for the response! i tried doing what you said … unfortunately it still is not working i tried “ half press “ .. then the hold dwn press once i do that little red specs are popping up not capturing the picture